Sailfish Extruder Calibration

Attempting to calibrate old FF Creator printer. At times my printer seems to over extrude and get blobs and stringing.

Tried various things, PLA, ABS, temperature, flow settings etc.

Running Octoprint but when I try and follow the example

some commands do not work and cannot find the steps per command to work like M503.

Can I follow the example above and change the Extruder? I ask cause of I tell Octoprint to Extrude 100mm - I ONLY extrude 83mm. Can someone help me?

Fine tuning something like the extruder motor is done with respect to EEPROM settings as stored on your printer's controller board.

It may be possible to install the EEPROM Marlin Editor plugin and to adjust this setting. You asked for 100 and got 83 so the ratio is easy enough. You need to multiply the value that's stored in EEPROM by 1.17 (100% + 17%) to adjust.

My printer is down for the moment so I can't go in there and identify which one it is.

But then again, you indicated Sailfish. Maybe this won't work. Hm... Check the TFT interface on the printer itself?

Hello I inherited this Monoprice clone of a Flashforge printer with the wood case. I found a web site and I thought it was a sailfish machine.

I just installed the Marlin EEROM plugin and it says my machine is not supported.

Okay, check the printer's TFT screen to see if there is a Settings feature to adjust things in the EEPROM. It might be under "fine tuning" or similar.

I couldn't tell you whether or not this is helpful.

Nothing in the LCD screen... Tried to get ReplicatorG running but I get a null ref exception.

OK I think the answer is staring at me ... if I open the GPX plugin and look at the settings for GPX I see this ..

So I think that looking at the extruder calibration I just need to know do I use 94.117 or 96.275 for

Original extruder steps/mm value Γ— 100 mm = total steps taken:
161.3 Γ— 100 = 16130 so 94.117 x 100 = 9411.7 ????

Multiply 96.27520 * 1.17 = 112.64

That multiplier is basically 1 + ((100.00 mm - 83.00 mm) / 100). Hopefully it writes that to the EEPROM. (You also want sliced code to use those amounts.)

OK Thanks so much - I will have to try again tomorrow.

Would I add this to the GCode?

Hello I think there is a bug - I have modified all values and when I use OP to extrude 100 mm it only extrudes 83 mm. I am not attempting to print anything just extrude from the Control tab in OP and even with rebooting the RPi.

I'm sure there's a proper way to do this (maybe in the Sailfish configuration or maybe in writing the EEPROM somehow with manual commands).

But you might try adjusting one of these two sliders to that 117% adjustment.