SD card storage issue


#1

What is the problem?
Installed Octopi Prusa Edotopm on my raspberry zero W and got everything set up.
However my "Fee disk space" shown in Octoprint is only 340MB out of 1.8GB. The SD card is 16GB.
I have not tried doing a clean octoprint install, I have only tried the Prusa edition version but I have a hard time believing that would be the problem.

What did you already try to solve it?
I tried expanding the filesystem with raspi-config, did not change anything.
Tried reflashing and installing, did also do nothing.

Here is partition and disk free:
putty

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Printer: Prusa i3 MK3
Octoprint: 1.3.6
Octopi: 0.14.0


#2

Since it's a modified version of the OctoPi image provided by Prusa Research (so not actually 0.14 but rather 0.14 PE or something), I strongly recommend you get in touch with them about any such problems. The issue is, I have no idea what exactly they did to the image, apart from apparently just booting up a fresh OctoPi, modifying some stuff and copying that back off the SD (which is not the recommended way due to various issues with this approach, and I've also gotten in touch with them about this).

What I can tell you though is that stock OctoPi happily expands the file system on first boot. So that was already done on this image when it was created at Prusa, and I can't remember right now how the initial resize worked on stock Raspbian but I think it was a one-time service which might have been removed on initial resize and hence neither automatic nor manual resize through raspi-config will work now.


#3

Thanks for quick answer, I will contact Prusa and see if they have had similar problems.
But your suggestions is to do a normal install and see if the problem persists?


#4

Yeah. Based on how that image was built, I'd actually not recommend using it until they've adjusted their build process. The necessary adjustments to have things work in "attached to the Einsy board" mode are well documented on the Prusa Forum as far as I know, and are not that much work.

As I said, that image has some problems due to how it was built. I've told them that, I also explained what they need to do instead, but I can't do it for them. If you use it, I strongly recommend against making it accessible over the internet for example (as in, do not create a port forward to your Pi, neither to OctoPrint running on it, nor to SSH running on it).

Adding to that, I also don't actually recommend using a Zero W, at least not if you also plan on attaching a webcam. The WiFi driver eats up hilarious amounts of CPU resources if you put any kind of network load on it, and that can severely effect print quality.


#5

That is some really valueble information!
I just followed their instructions and I was quickly up and running. I will try a fresh install and post about the results.

Right now I have it accessible over the internet via port forward, :disappointed_relieved: and the only security is Acess Control. I will change this with the new installation.

I will get a more powerful pi aswell, maybe a model 3 B. Weird that they recommend the pi if it doesn't have the CPU resources. I have had my zero setup with camera, etc and printing and no signs of effect on print quility. :hushed:


#6

Going for the original version of OctoPrint solved this issue. The problem is in the Prusa Edition.