Seeking configuration for Insta360 One R as Octolapse camera

Camera model Insta360 One R, 4K mod

What is the problem? Cannot find a configuration that will work for the Insta360 One R camera. (Logitech camera works fine.) When I test /webcam2/?action=stream in octoprint settings, I get a broken-image icon next to the text that says: If you see your webcam stream below, the entered stream URL is ok. I have also tried this with only the Insta360 camera installed, and with the camera_usb_options mentioned below moved to the /boot/octopi.txt file. Of course v4l-ctl output is adjusted accordingly, but that is the only change. No joy.

What did you already try to solve it? In /boot/config.txt, set camera="usb" and camera_usb_options="-r 1920x1080 -f 30 -d /dev/v4l/by-id/usb-Amba_Insta360_One_R-video-index0" (I also tried -f 10, to no avail)

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support) (I do not see such a file. /etc/default/webcamd indicates that such a file should be created, but it is not in /var/log as it should be although this is in that file: LOG=/var/log/webcamd.log

I will be thrilled to share that file if we can make it appear.

Additional information about your setup (OctoPrint version, OctoPi version, ...) OctoPrint 1.6.1, Octopi 0.17.0, running on Raspberry Pi 3 Model B Plus Rev 1.3

output from v4l2-ctl --list-devices

bcm2835-codec-decode (platform:bcm2835-codec):

bcm2835-isp (platform:bcm2835-isp):

Logitech Webcam C930e (usb-3f980000.usb-1.1.2):

Insta360 One R: Insta360 One R (usb-3f980000.usb-1.3):

Created a directory /boot/octopi.conf.d

List of camera devices:

ls -l /dev/v4l/by-id/
total 0
lrwxrwxrwx 1 root root 12 Nov 30 20:20 usb-046d_Logitech_Webcam_C930e_0DDAA26E-video-index0 -> ../../video0
lrwxrwxrwx 1 root root 12 Nov 30 20:20 usb-046d_Logitech_Webcam_C930e_0DDAA26E-video-index1 -> ../../video1
lrwxrwxrwx 1 root root 12 Nov 30 20:37 usb-Amba_Insta360_One_R-video-index0 -> ../../video2
lrwxrwxrwx 1 root root 12 Nov 30 20:37 usb-Amba_Insta360_One_R-video-index1 -> ../../video3

Content of /boot/octopi.conf.d/webcam2.txt:
camera_usb_options="-r 1920x1080 -f 30 -d /dev/v4l/by-id/usb-Amba_Insta360_One_R-video-index0"
camera_http_webroot="-n -p 8081"

I have also modified /etc/haproxy/haproxy.conf:

        maxconn 4096
        user haproxy
        group haproxy
        log local1 debug

        log     global
        mode    http
        option  httplog
        option  dontlognull
        retries 3
        option redispatch
        option http-server-close
        option forwardfor
        maxconn 2000
        timeout connect 5s
        timeout client  15min
        timeout server  15min

frontend public
        bind :::80 v4v6
        bind :::443 v4v6 ssl crt /etc/ssl/snakeoil.pem
        option forwardfor except
        use_backend webcam if { path_beg /webcam/ }
        use_backend webcam2 if { path_beg /webcam2/ }
        default_backend octoprint

backend octoprint
        acl needs_scheme req.hdr_cnt(X-Scheme) eq 0

        reqrep ^([^\ :]*)\ /(.*) \1\ /\2
        reqadd X-Scheme:\ https if needs_scheme { ssl_fc }
        reqadd X-Scheme:\ http if needs_scheme !{ ssl_fc }
        option forwardfor
        server octoprint1
        errorfile 503 /etc/haproxy/errors/503-no-octoprint.http

backend webcam
        reqrep ^([^\ :]*)\ /webcam/(.*)     \1\ /\2
        server webcam1
        errorfile 503 /etc/haproxy/errors/503-no-webcam.http

backend webcam2
        reqrep ^([^\ :]*)\ /webcam2/(.*)     \1\ /\2
        server webcam2
        errorfile 503 /etc/haproxy/errors/503-no-webcam.http[|attachment](upload:// (122.3 KB)

Turns out that disabling Spaghetti Detective was key to making this operation work. I had read here that Spaghetti Detective has some problems with multiple camera setup, but the way it was written, sounded like Spaghetti Detective would have the problem, rather than the multicam setup itself having problems.

I tried disabling that since no other things seemed to work when they should, and voila! problem, solved!

1 Like