Segmentation fault, something to do with mjpg_streamer when stream starts

Camera model:

What is the problem?: After connecting the webcam with the blue part of the ribbon cable facing the RJ45 and the back side of the camera.

What did you already try to solve it?

I have tried FF, IE, Edge, Chrome. I have read the logs. I have rebooted, updated, restarted, everything of the sort. I have checked configs, etc.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

webcamd.log (24.2 KB)

Additional information about your setup (OctoPrint version, OctoPi version, ...)

Raspberry Pi 3 B+
OctoPrint 1.5.2
Python 2.7.16
OctoPi 0.17.0

Which Pi and which Octopi version are you using?

Raspberry Pi 3 B+
OctoPrint 1.5.2
Python 2.7.16
OctoPi 0.17.0

Mine appears to be a duplicate of this:
Webcam stream url no longer response - Get Help / Webcams - OctoPrint Community Forum


not quite - that user had a seg fault at another line.
I was waiting for one of our programmers - maybe they know what to do.
All I can tell you is that a seg fault often is caused by memory errors which could be caused by problems with your power supply.
Like when you use a phone charger instead of a power supply, a power supply with not enough amps, a usb device which is drawing too much power (like your printer when it is not turned on or an external hdd) and so on.

I would suggest you disconnect all usb devices, use a sufficient psu, flash a fresh image on your sd card and try over.
Maybe it helps fingers crossed :slight_smile:

Using a Samsung 5.3v 2.0a phone charger. I figured it was sufficient as a power supply. Already in the middle of a clean flash. Sucks to lose the configs.

A phone charger is not a power supply. A phone won't mind too much if the voltage dips a little from time to time; your Raspberry Pi does. A phone will consume a fairly constant amount of power; your Raspberry Pi does not.

1 Like

Segmentation faults happen when a program tried to access some memory it cannot, either because it is not supposed to (doesn't belong to the program) or because it does not exist. I'm not an expert with these, but often it is very difficult to trigger them.

It can be caused by corruption I think, maybe power supply, just generally something is not right deep within the system.

It looks like there were some issues with segfaults using MJPG Streamer on 64 bit OS, but you're using OctoPi 0.17 so must be 32 bit.

In short, we don't really have an idea beyond the install might have gone badly/corrupted/throttled due to low power (which makes it do strange things...)