Serial Connection to FLSun SR

What is the problem?

My FLSun SR printer is not connecting to Octoprint. OTG cable is plugged in using the cable sent with the printer.

What did you already try to solve it?

I read online that the baud rate needed to be 256000 so that's been tried, still no love.
Changed connection from Auto/Auto to Auto/256000
Verified OTG with usb thumb drive
Of course, reboot everything several times.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (6.2 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint- 1.7.3 - Fresh install
Phone: LG V20 - ATT M910 version
Printer - FLSun SR Marlin Firmware
Changing monitoring state from "Offline" to "Opening serial connection"
Connecting to port /dev/ttyOcto4a, baudrate 256000
Changing monitoring state from "Opening serial connection" to "Connecting"
Connected to: Serial<id=0x7e7848ac40, open=True>(port='/dev/ttyOcto4a', baudrate=256000, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Send: N0 M110 N0125
No answer from the printer within the connection timeout, trying another hello
Send: N0 M110 N0
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

I literally have the same issue with my Kywoo3D Tycoon Slim... Hope somebody has a solution. I've tried everything as well... from playing with intervals and timeouts, to electrical tape on the VCC of the USB cable just in case there is backpowering... I've tried 3 different OTG adaptors (2 Y splitter type with PD and one just USB A to USB C), 2 PCs (Desktop and Laptop), 2 phones (LG G5 and G7)... Literally don't know what else to do!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.