Serial Exception - BTT SKR 2, Ender 3 v2

What is the problem?

Ender 3 v2 with SKR 2, latest Marlin firmware. Anywhere between 20 and 40 hours of octoprint being connected to my printer, it will throw a serial exception "SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?)".

Lately, this becomes permanent, as in I can connect octoprint to my printer but after 20-30 seconds, it throws the same serial exception. The only way to fix this, is to reflash the firmware. Then, the same cycle continues. 20-40 hours of printing, serial exception, and eventually its permanent.

What did you already try to solve it?

  1. I typed 'SKR 2 Serial Exception" into the Octoprint Get Help Topic search bar and it only showed 10 results, none of which were useful.
  2. I've spent hours and hours googling and reading other people's serial exceptions issues and nothing seems to match mine.
  3. I've tried running Octoprint in Safe Mode
  4. I've tried removing my BTT TFT 50 screen in case the serial port was interfering. No difference.
  5. I've tried different USB cables and different USB ports.
  6. I've tried rebooting octoprint and restarting Octoprint and as previously stated, running Safe Mode.
  7. Reflashing the firmware solves the permanent issue, but it eventually returns.

Have you tried running in safe mode?

Yes. I'm not good at this stuff but the log seems to show that OctoEverywhere was still active, even in safe mode and it looks like the issue might be caused by OctoEverywhere. However, I don't know how to properly read the logs so don't take my word on that.

Did running in safe mode solve the problem?

No it did not

Systeminfo Bundle (456.8 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Ender 3 v2
Dual Z
TMC2209 x 5
Raspberry Pi 4B
11250 Baud Rate

I've tried reversing them so that SERIAL_PORT is 1 and SERIAL_PORT_2 is -1
Again, the TFT is still disconnected so there is only one serial port being used until I sort this out.

Additionally, it doesn't matter if I'm trying to print or not, the serial exception still occurs if Octoprint is just idle.

This was not an issue with the original creality V4.2.2 mainboard.

If you require more information, please ask!

Thanks in advance,

Edit: I also have a nuisance issue where when I first connect to the printer, I get "Media Init Fail" and my uploaded files don't show up. If I refresh the list or upload a new file, the list reappears.

Alright, I solved this on my own. Doesn't make a lot of sense but if you are having the same issues as me, take a look at this thread on Reddit Reddit - Dive into anything

I'm not sure how or why, but leaving the SD card in the SD slot on the BTT SKR 2 causes Marlin to restart every few minutes. For me, this issue wouldn't happen immediately. It would work fine for a few days, and then restart and eventually restart every few minutes, unless I reflashed the firmware. That being said, I only realized it was the printer restarting because I happened to notice that the LEDs on the board turned off when Octoprint lost its connection.

I've since removed the SD card and my printer has been working without issues since I made this post. I didn't have to reflash the firmware to fix it either, simply removing the SD card fixed it.

I hope this helps someone else!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.