Serial port connection issue on mac OS X


All my Arduino clones (Uno and Mega) work fine in High Sierra. Let me see if I can find the FTDI driver I have installed and get the link...maybe that will help in your case. It also allows my USB-to-serial adapter I use for Cisco console connections to work properly.


Here's the info from the loaded kernel for the 1.6.0 Prolific PL2303 USB to Serial and try it.


Version: 1.6.0
Last Modified: 9/22/15, 11:15 AM
Bundle ID: com.prolific.driver.PL2303
Loaded: No
Get Info String: ProlificUsbSerial v1.6.0, Copyright 2006 Prolific Technology Inc.
Obtained from: Identified Developer
Kind: Intel
Architectures: x86_64
64-Bit (Intel): Yes
Location: /Library/Extensions/ProlificUsbSerial.kext
Kext Version: 1.6.0
Loadable: Yes
Dependencies: Satisfied
Signed by: Developer ID Application: Prolific Technology Inc. (2MP849R8J5), Developer ID Certification Authority, Apple Root CA

Or try the Mac OS X Silicon Labs driver...I have it loaded too.

Also an extension for the CH34x chips is in this blog post:


All my Arduino clones (Uno and Mega) work fine in High Sierra. Let me see

if I can find the FTDI driver

Some boards use the WCH chips. Those need a different driver.

You should be able to see the Vendor ID in the System Information App and
work out from there if you need FTDI, WCH or some other driver.

Additionally while searching for this I found reports that the FTDI drivers
will actively not work with clone FTDI chips. (I can see their point, but
that could prove very frustrating, punishing the victims not the offenders)


on my arduino is the ch34xx chip

does not work.


Hi Andy, yes the printer shows up as the screenshot attached!

I'm thinking I may have to try another USB port maybe...


Hi, I already tried both FTDI, Silabs and ProlificUSBserial but they don't appears In the OctoPrint Serial Port menu after install (I could not figure out how to do so properly, I may have to try again).

Thanks I will check and look for CH34x too later tomorrow ! :slight_smile:


OK Thanks for the tips, I may give a try too... while searching I've seen many Arduino users having Serial Port issues with this OS X 10.11 version

... serial port does not show up in /dev/tty*

FYI I'm not a Arduino or Raspberry Pi user a this time yet.


Ok it looks like that you have to use the CH341SER driver.
these are on their google drive.
But on high sierra you can try these from the links in my upper post.
10.13.3 they worked.


Thanks I'll try tomorrow, keep you posted.


Hi I (re)tried all mentioned solution (drivers) above without any success. osX 10.11.x and/or OctoPrint does not seems recognize such 'SerialPort' properly both Manually or in AUTO mode.

Error: Failed to autodetect serial port, please set it manually.

I guess there is an issue with OS X 10.11 (elCapitain), I cannot test it on more recent system for now...


I get an advice from Profab3D to try with Printrun / Macpronterface...
First I've (re)installed (without SIP) the Prolific PL2303 driver and now I have a new serial port visible:


Then I've installed Printrun from the latest OSX binaires from

Good news: Macpronterface can connect to my printer using this PL2303 serial port *.usbmodem1D11
Bad news: any idea why OctopPrint doesn't connect in this case using this same port ?



have you tried to set the port manual / if i try to use the auto detection it doesn't work / but when i set it manually it works with el capitan.


Probably because that string is not part of the device paths it assumes to be possible printers and hence it doesn't even look for it. Try adding


to Settings > Serial Connection > General > Connection > Additional serial ports:

Save, then refresh your browser.


But yes it is part of the string... (as attached).
I tried to add it manually too, and I get the port name twice, but still no connection.
I tried Auto and Manual on various port again as suggested above by Daniel, still nothing.
Iv'e add the log for more details...
Thanks for all your support.

octoprint-20-4-18.log (35.9 KB)


That's a bit embarassing. I honestly managed to overlook the pattern matching those entries in the default list of patterns. My bad :sweat_smile:

The application log isn't really helpful in case of communication issues with your printer. Enable serial.log, try connecting, provide that.


Oh My bad too... i did check the serial.log check box, but it look's like I've deleted it by mistake: However I did not noticed there was a list of so much various logging options… :slight_smile:

Here is some logs… but I don't see much more information there.

octoprint.log (56.2 KB)
serial.log (813 Bytes)
serial.log.2018-04-20_12-16-42.log (809 Bytes)
serial.log.2018-04-20_12-12-42.log (5.0 KB)
serial.log.2018-04-20_12-13-42.log (813 Bytes)


Your printer is sadly not replying to OctoPrint's desperate attempts to get a communication going at any port or baudrate there. You said it did work with Macpronterface. What exact port and baudrate did you use there?

/dev/cu.usbmodem1D11 @115200

but something is odd now... I'm trying again with Macpronterface and it's not connecting too... I'll try to reboot and get back to you


ok sorry some good news after reboot i did those things:

  1. Disabled SIP (System Integrity Protection) totally again, because yesterday I've enabled it again partially this way csrutil enable --without kext after testing Macpronterface...
  2. csrutil disable and restart osx and Macpronterface
  3. At first I had no connection..., I had to reset the printer with Macpronterface UI
  4. using /dev/tty.usbmedm1D11 @ 115200 baud
  5. status: connected (finally)
  6. I disconnected from Macpronterface and start Octoprint and try to connect on the same port / baud
  7. Tadaaaa... status: Operational
  8. so… I will investigate if it is really the "SIP" which cause this interference and will try to post that later…
    because I have to work a bit and stop playing :slight_smile:
    Thanks all for your support !


On my GA Z77 DSH3 Mainboard with 10.13.4i have SIP deactivated.
On my Macbook late 2015 not and it works without disabling SIP.
But as i wrote i use Docker so octoprint runs with linux :wink: