Serial port connection issue on mac OS X


#1

What is the problem?
My printer is not detected via USB (? serial port) on my mac pro

What did you already try to solve it?
I've tried many way to use AUTO ou manual Serial Port connection without any success.
I'm quite new to understanding "serial port" connection on mac and it seems my osx version does not have the right driver.
Iv'e google a lot and try to install or configure various settings using terminal command such as "minicom" or "screen" but I'm a bit lost with that as I am not a developper... I'm sure I am going the wrong way...

Additional information about your setup

Mac osx 10.11.6 (el capitain) on Mac Pro 3,1
Octoprint version: 1.3.7 — server is running fine (installed with Macport without any issue)
Printer: ProfabMini+ (it's a updated MP select Mini version) connected via USB
This printer has also WI-Fi connection capabilities working fine with default settings (but the UI is too limited)
Plugins: Malyan/Monoprice Connection Fix (0.1.0) installed

Serial log:

2018-04-11 12:24:00,798 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-04-11 12:34:19,364 - octoprint.util.comm - INFO - Changing monitoring state from "Offline" to "Opening serial port"
2018-04-11 12:34:19,373 - octoprint.util.comm - INFO - Changing monitoring state from "Opening serial port" to "Detecting baudrate"
2018-04-11 12:34:19,393 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2018-04-11 12:34:29,396 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
... etc.
2018-04-11 12:35:47,069 - octoprint.util.comm - INFO - Changing monitoring state from "Detecting baudrate" to "Error: No more baudrates to test, and no suitable baudrate found."
2018-04-11 12:35:47,072 - octoprint.util.comm - INFO - Changing monitoring state from "Error: No more baudrates to test, and no suitable baudrate found." to "Offline (Error: No more baudrates to test, and no suitable baudrate found.)"

Additionnal question: Is there a way to connect this printer through Wifi to Octoprint the server directly via Wifi installed on my mac without using OctoPi ?

Thanks in advance for your help!


#2

install the driver if needed


#3

Sorry but which driver are you talking about ?


#4

The various USB to serial chips used on printers (and Arduinos and their
clones) need a driver so that they appear on the Mac as a serial port.
You should be able to see what the USB to Seril device is by loooking in he
"System Information" panel on the Maac and looking at the USB buses.
(See what appears and disappears when you plug / unplug. Apple-R refreshes
the view.)


#5

And when you have High Sierra installed you are f*#!$§%ed :wink:
I got none of my arduino clones working / El Capitan is fine.

I sent you a program which reads out your usb devices / you can upload the result in this thread and then we can look which drivers you have to install ...


#6

All my Arduino clones (Uno and Mega) work fine in High Sierra. Let me see if I can find the FTDI driver I have installed and get the link...maybe that will help in your case. It also allows my USB-to-serial adapter I use for Cisco console connections to work properly.


#7

Here's the info from the loaded kernel extension...search for the 1.6.0 Prolific PL2303 USB to Serial and try it.

ProlificUsbSerial:

Version: 1.6.0
Last Modified: 9/22/15, 11:15 AM
Bundle ID: com.prolific.driver.PL2303
Loaded: No
Get Info String: ProlificUsbSerial v1.6.0, Copyright 2006 Prolific Technology Inc.
Obtained from: Identified Developer
Kind: Intel
Architectures: x86_64
64-Bit (Intel): Yes
Location: /Library/Extensions/ProlificUsbSerial.kext
Kext Version: 1.6.0
Loadable: Yes
Dependencies: Satisfied
Signed by: Developer ID Application: Prolific Technology Inc. (2MP849R8J5), Developer ID Certification Authority, Apple Root CA

Or try the Mac OS X Silicon Labs driver...I have it loaded too.

https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers

Also an extension for the CH34x chips is in this blog post:


#8

All my Arduino clones (Uno and Mega) work fine in High Sierra. Let me see

if I can find the FTDI driver

Some boards use the WCH chips. Those need a different driver.

You should be able to see the Vendor ID in the System Information App and
work out from there if you need FTDI, WCH or some other driver.

Additionally while searching for this I found reports that the FTDI drivers
will actively not work with clone FTDI chips. (I can see their point, but
that could prove very frustrating, punishing the victims not the offenders)


#9

on my arduino is the ch34xx chip
http://www.wch.cn/download/CH341SER_MAC_ZIP.html
and


does not work.


#10

Hi Andy, yes the printer shows up as the screenshot attached!

I'm thinking I may have to try another USB port maybe...
Eric


#11

Hi, I already tried both FTDI, Silabs and ProlificUSBserial but they don't appears In the OctoPrint Serial Port menu after install (I could not figure out how to do so properly, I may have to try again).

Thanks I will check and look for CH34x too later tomorrow ! :slight_smile:


#12

OK Thanks for the tips, I may give a try too... while searching I've seen many Arduino users having Serial Port issues with this OS X 10.11 version

... serial port does not show up in /dev/tty*

FYI I'm not a Arduino or Raspberry Pi user a this time yet.


#13

Ok it looks like that you have to use the CH341SER driver.
these are on their google drive.
But on high sierra you can try these from the links in my upper post.
with
10.13.3 they worked.


#14

Thanks I'll try tomorrow, keep you posted.
Best


#15

Hi I (re)tried all mentioned solution (drivers) above without any success. osX 10.11.x and/or OctoPrint does not seems recognize such 'SerialPort' properly both Manually or in AUTO mode.

Error: Failed to autodetect serial port, please set it manually.

I guess there is an issue with OS X 10.11 (elCapitain), I cannot test it on more recent system for now...


#16

Hi,
I get an advice from Profab3D to try with Printrun / Macpronterface...
First I've (re)installed (without SIP) the Prolific PL2303 driver and now I have a new serial port visible:

/dev/cu.usbmodem1D11
/dev/tty.usbmodem1D11

Then I've installed Printrun from the latest OSX binaires from http://kliment.kapsi.fi/printrun/

Good news: Macpronterface can connect to my printer using this PL2303 serial port *.usbmodem1D11
Bad news: any idea why OctopPrint doesn't connect in this case using this same port ?

Best,
Eric


#17

have you tried to set the port manual / if i try to use the auto detection it doesn't work / but when i set it manually it works with el capitan.


#18

Probably because that string is not part of the device paths it assumes to be possible printers and hence it doesn't even look for it. Try adding

/dev/*.usbmodem*

to Settings > Serial Connection > General > Connection > Additional serial ports:

Save, then refresh your browser.


#19

But yes it is part of the string... (as attached).
I tried to add it manually too, and I get the port name twice, but still no connection.
I tried Auto and Manual on various port again as suggested above by Daniel, still nothing.
Iv'e add the log for more details...
Thanks for all your support.


octoprint-20-4-18.log (35.9 KB)


#20

That's a bit embarassing. I honestly managed to overlook the pattern matching those entries in the default list of patterns. My bad :sweat_smile:

The application log isn't really helpful in case of communication issues with your printer. Enable serial.log, try connecting, provide that.