SerialException / Consecutive Communication Timeouts

You are getting an eyeful. I'm sorry. However, I doubt you'll be able to call me one of the people who didn't provide enough info. You're getting ALL OF IT.

I've been through two+ solid weeks of HELL and I've read / watched so many forum posts and articles and videos that my eyes are bloodshot and my brain is addled

I cannot read any other posts that are over a year old, for printers not even of the make/model/firmware as mine, or end up being for some weird third party program that isn't a Raspberry PI connecting to a 3D printer through Octoprint.

See the APPENDIX & CHRONOLOGY at the very bottom with the entire span of month-old printer -- which I dearly love using (when it was working) -- specifically the part from "Week Three" forward.



What is the problem?
SerialException: I read the SerialException FAQ.

Note all the steps I took to solve SerialException errors. I state them because unless that cable wiggles (!@#$) because I bump it mid-print, the SerialException errors seem to be solved. Now, however, I encounter:

No response from printer after 3 consecutive communication timeouts, considering it dead. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.
Error: Too many consecutive timeouts, printer still connected and alive?)



What did you already try to solve it?
In order of the bullet points (but not necessarily how I applied them):

  • Good power supply
    • Red LED doesn't flicker.
  • USB peripherals
    • Removed webcam from Raspi, even though it'd been running for well over 1.5 weeks just fine.
  • Serial connection from another process
    • Closed Cura and PuTTY...just in case.
  • Your printer's USB cable came loose
    • I first created a brace to bolt onto the printer, but sometimes it's still not holding tight. I've resorted to electrical tape.
  • Cable internal breakage
    • Swapped the cable out four times of what I had on hand. Original cable was purchased new with the Raspi at the beginning of this month.
  • Shielded Cable
      • That was the shortest I could find on Amazon
    • The cable out from the printer goes to the left, and on a shelf above (and to the left) where the Raspi sits.
  • cmdline.txt Edit
  • *At some point, I did this. I just realized now, I haven't gone back and made the edit since.

SerialException was solved (?)

    • After ALL the above was done, and purely because I happened to have and old Belkin 7-Port F5U027 laying around, I plugged in a powered USB hub.
      • SerialException Errors stopped (unless I accidentally bump the (!@#$) cable.
      • However, now I'm getting the communication timeouts.
  • Taping the VCC pin on the USB Cable

    • This was done both before the hub and even after the hub
    • Whenever I tape the right-most pin -- whether from raspi-to-hub, hub-to-printer, or both -- Octoprint fails to detect the serial port.
      • "Error: Failed to autodetect serial port, please set it manually."
    • If I swtich and tape the left-most pin, it will detect it and it will print, but I will eventually get a consecutive connection error.


Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

  • Items in shared Dropbox folder
    • serial.log from start of print around 1:30am through 10:30am this morning
    • octoprint.log (ibid)
    • Firmware h files
      • Configuration
      • Configuration_adv
    • GCode for Pulley Tensioner part I was printing
      • NOTE: This print DID actually complete.*
        • It was 2hrs 3min, so it printed somewhere before 4am.
        • Then, the printer sat just fine for hours until it randomly disconnected around 7am.


Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)




APPENDIX & CHRONOLOGY

  • Week One: May 26, 2020
    • Installed Ender 3 Pro
      • Only put yellow springs on because friends and forums said, "run it stock for awhile until you get used to it" and my bed wasn't packaged with the leveling knobs on at all and all the springs just fell off.
    • Great prints (Chep cubes, Micro Tower all-in-one tests, cable clips, cable chain, a couple D&D minis, rando parts for house hold items) for a week.
    • Printed like magic.
    • Never had issues with leveling, adhesion, globs, stringing, spaghetti, clogs, or any other nightmares because I watched the HELL out of YouTube and researched forums before I started ordering everything back in early April.
  • Week Two
      • Had burned through 80-90% of a roll of black PLA by now and switched to some gray PLA+.
        • Tweaked temperature, but still, kept printing like mad and things looked great.
    • Decided I was too lazy so I decided to get the Raspberry Pi and install Octoprint.
      • Ran like a dream for a week.
      • Hooked up an old Microsoft webcam to be upgraded later, but hey, it's video, and I can spend time with my wife upstairs, rather than babysit the printer in the basement.
    • More tweaking of settings, layers looked near-flawless
  • Week Three through last Friday
    • Was getting close to running through the gray PLA+
    • Switched to white PLA.
      THE WORLD STOPPED
    • Sudden constant leveling issues (despite two weeks+ of it fine as noted above)
      • X-axis pulley loosened (finally got tightened)
      • Leveling screws were rotating (used lock washers at first)
    • Attempted Fixes
      • Decided to install the BLTouch I'd ordered but not installed ("run it stock")
      • Ordered a glass bed: because two days of REALLY bad leveling had gouged the hell out of my magnetic surface
      • Discovered the idea of Nylock nuts and bought some locally.
    • To install the BLTouch, I had to flash a bootloader, and since I was doing that and couldn't find (at first) 1.1.6.2, I made the jump to Marlin 2.x to try and root out other bugs rather than using Year+ old firmware.
    • SerialException errors kicked in
    • I ditched 2.0 (bugfixes or no made no difference) so I dropped to 1.1.9+bugfixes
    • Regardless, it was a solid week of fighting fruitlessly until...
  • March 27, 2020
    • I put in the powered USB (see below).
    • Firmware for 1.1.9 ran clean. BLTouch worked.
  • March 28, 2020
    • Ran leveling tests and PIDs all afternoon and into the evening.
    • SerialException stopped except for times when the cable came loose.
    • Now, started getting "Too many consecutive timeouts"
      • Posts here and on reddit were often referencing more current versions of Marlin so...
    • Late Sunday night, I pushed Marlin 2.x+Bugfix and things started to look good
  • March 29, 2020
    • Left the printer on overnight, only to see a "Too many consecutive timeouts" came in and it disconnected.
    • Rebooting the server fixes it, but it loses (of course) wherever it was printing)
    • Attempted several times to print off the belt tensioner parts (the last thing I had nearly completely before the world stopped), and it disconnected five times.
  • March 30, 2020 (posting date of this log)
    • The part managed to actually print overnight, but then, while sitting idle, it just disconnected.
    • I tried one last time to put the tape of the USB cord on the right-most position instead of the left
      • "Error: Failed to autodetect serial port, please set it manually."
      • And so now I'm posting this log.
  • July 1, 2020
    • Firmware Changes:
      • Attempted to make updates on serial ports as discussed here, but it wouldn't compile.
      • No effect: Still got consecutive communication timeouts.
        • Will be reviewing ALL of the changes -- recommended or random "fixes" next.
    • Hardware changes
      • No effect: Still got consecutive communication timeouts.
  • July 1, 2020 Part II: Serial Boogaloo
    • Serial Corruption......and probably not OctoPrint in any way shape or form.
      • For the first time tonight, Cura crashed while trying to print over USB.
      • Shutting down Cura, Pronterface couldn't connect via USB either.
      • Shut down printer, changed USB ports on PC, no effect.
      • Had to completely reboot the PC (twice) in order to reset it.
    • Unless someone actually has an idea of how to fix this I'm 100% back to the drawing board on this, but I'll leave it up here for posterity.
      • I have no fucking clue where to go from here.
1 Like