Serice octoprint will not start

What is the problem?

Service will not start

What did you already try to solve it?

Today I download octoprint, create SD card with octoprint and upload it to rapsberry pi.
after it didn't work I
try to reinstall it and update it and it is the same
try to find octoprint.log and doesn't exist.

here is web log

The OctoPrint server is currently not running

If you just started up your Raspberry Pi, please wait a couple of seconds, then try to refresh this page.

If the issue persists, please log into your Raspberry Pi via SSH and check the following:

  • Verify that the process is running: ps -ef | grep -i octoprint | grep -i python should show a python process:

pi@octopi:~ $ ps -ef | grep -i octoprint | grep -i python
pi 1441 1 6 11:12 ? 00:00:15 /home/pi/oprint/bin/python
/home/pi/oprint/bin/octoprint --host= --port=5000

  • If it isn't, the question is why. Take a look into ~/.octoprint/logs/octoprint.log, there might be an error logged in there that helps to determine what's wrong.
  • You might also want to try if you can restart the server (if no obvious error is visible): sudo service octoprint restart.

If all that doesn't help to trouble shoot the issue, you can seek support on the OctoPrint Community Forum. Please provide your OctoPi and OctoPrint versions as well as your octoprint.log and explain what you already tried and observed as detailed as possible.

Have you tried running in safe mode?

No, it doesn't work. This is the only config.yaml

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I have found these folders and files and it exist.

Nov 13 17:42:29 pi systemd[3607]: octoprint.service: Failed to execute /home/daman/oprint/bin/octoprint: No such file or directory
Nov 13 17:42:29 pi systemd[3607]: octoprint.service: Failed at step EXEC spawning /home/daman/oprint/bin/octoprint: No such file or directory

could you try another sd card? just to rule that out.

First I use 8Gb sd card didn't worked.
Now I use 16Gb card
Now I can ping rapsberry IP but can not access by web I have flashed SD card 3 times and it is the same
red light is on and green is flasihng.

This site can’t be reached refused to connect.

Sounds more like a network issue.
What happens if you connect the pi via Ethernet?

I finally manage to solve this. I put in another SD card and flash it for 8 time and than it start to work ok. Now everything is fine.
Thank you for helping


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.