πŸ‡ΊπŸ‡¦ We stand with Ukraine! πŸ‡ΊπŸ‡¦

Server currently not running

What is the problem?

Left a print running and came back to a failed print half way through and cannot connect to the server anymore.

What did you already try to solve it?

Able to log into Pi via SSH using putty and winscp
After looking at some infor here ran ~/oprint/bin/octoprint serve and got
OSError: [Errno 28] No space left on device
I then ran df -h and got the following
Filesystem Size Used Avail Use% Mounted on
/dev/root 59G 59G 0 100% /
devtmpfs 1.7G 0 1.7G 0% /dev
tmpfs 1.9G 0 1.9G 0% /dev/shm
tmpfs 1.9G 8.5M 1.9G 1% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 1.9G 0 1.9G 0% /sys/fs/cgroup
/dev/mmcblk0p1 253M 49M 204M 20% /boot
tmpfs 379M 0 379M 0% /run/user/1000

How did It /dev/root get loaded with 59gigs of data in a matter of less than 8 hrs?Is there a way to fix it without starting from scratch
Looking at the logs a plugin octoeverywhere kept getting an error and my guess is that It just ran out of space? At this moment I don't know what to do

Have you tried running in safe mode?

Dont Know how

Did running in safe mode solve the problem?

N/A

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint.log (148.9 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Ender3 V2 Octoklipper

Octoprint in Octopi uses those folders by default

Bildschirmfoto vom 2022-06-18 16-08-56

I guess it was a timelapse - so I would check those folders first.
(replace pi with your username if you changed it)

Every now and then we have seen an issue with the wifi on the Pi erroring out and filling the card with error messages relating to it failing. This would be in line with the fact that the OctoEverywhere plugin was failing to connect to it's server, if the wifi firmware was broken.

Check ls -lh /var/log/ and see if the syslog and kern.log are quite large.

2 Likes

Thanks I ran it and this stands out
total 54G
a long list of files but the following 3 with today's date look abnormal
-rw-r----- 1 root adm 27G Jun 18 09:20 kern.log
-rw-r----- 1 root adm 17G Jun 18 10:59 syslog
-rw-r----- 1 root adm 11G Jun 18 00:00 syslog.1

Should I just delete these logs? IF I can and this fixes the issue I will disable octoeverywhere until I figure out what is causing the plugin error

You can just delete them - that would allow OctoPrint to start up again.

The issue is very rare but I have seen it a handful of times before - never again after a reboot for the same person, however. So you may not be able to 'figure out' what is causing the error, it is (most likely) a bug with the RPi wifi firmware. They are not known for being the most reliable.

Thanks
Now how do i access the location of these logs to delete?
Cant seem I do find them via WinSCP or do i need to do this via putty. If so how?
My apologies for the many questions really a noob at this

The command would just be sudo rm /var/log/<one of the files>, repeated to delete whichever file you wanted.

Worked Server up and running thanks!

Glad you found the issue.

If you or anyone else got a similar case and you aren't sure what folders got filled up, try ncdu.

Install it with sudo apt install ncdu and run it with sudo ncdu /.

Of course you need some free space for the installation, but it shouldn't be much. Just delete a few gcodes and/or timelapses.