Server Offline as soon as trying to access Octoprint from a browser


#1

What is the problem?

I have been successfully using octoprint for many months now. Recently I have started to get server is offline error as soon as I try to access Octoprint from a browser.

What did you already try to solve it?
I have tried rebooting Pi
I looked at the forum for similar cases. I couldn't find a feasible solution.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Octoprint Version: 1.3.8
OctoPi Version: 0.14.0
Printer: Prusa i3 mk2s
Firmware: Marlin

I can sucessfully SSH into the Pi using my computer.

octoprint.log (14.5 KB)


#2

Assumptions:

  • Your workstation is at a college
  • The printer is at that college
  • Your I.T. staff have made changes to their internal firewalls
  • Those IP addresses in your log ARE PUBLIC IP ADDRESSES!!!!1!1111

I can only hope you've setup access control on that.


#3

Your first two assumptions are right. The printer is in a lab in a university.
It is possible that recent changes to firewall are made by IT staff

Though the IP addresses look public, they are not visible to outside world. They can be only accessed through a special VPN.

Ofcourse, the access control is turned ON with https authentication.

So, do you think the problem is with the changes in firewall rules? Can it be narrowed down?


#4

Run Octoprint with your plugins disabled. See if that helps.


#5

Plugins might not be the issue here. But I can try.

How can I run octoprint with plugins disabled? The server immediately disconnects when I try to access Octoprint server from a browser.


#6

Presumably, some sort of ~/.octoprint/config.yaml editing might do that without the web interface.

As a long-time I.T. Manager, I would imagine that someone could have edited the internal firewalls at the college. It sort of looks like you and the printer are on the same subnet of your CLASS C or whatever you have there. Even so, I know places where there is limited peer-to-peer connectivity on the wi-fi network due to security concerns.

You might try both the http: and https: versions of your printer's interface.


#7

See How to start OctoPrint in safe mode - there are several ways.


#8

I finally traced the issue back to internal IT firewall. It is now resolved.


#9

It's always the I.T. staff... :man_facepalming: