Server Quits When I hit "Print"


#1

What is the problem?

I have been printing with my Ender 3 and Rostock Max v3 for 2 weeks now using multiple instances. I haven't had any problems. Now all of a sudden I can control the Rostock (10.0.0.201) just fine up until I click "print" then the "server stopped working" message comes up. To get back to controlling it again I have to ssh in and restart the service. And on top of that, I can't even load my Ender 3 which is running on (10.0.0.201:5001). I haven't been able to get that back.

I have a suspicion that it is the power supply? I am using a Samsung fast charger, but the light is still on and I have that undervoltage message at the top of my octoprint gui.

What did you already try to solve it?
Run the error log stuff, says permission has been denied. Restarted octoprint through ssh.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

0.16.0 and 1.3.10

Not sure why it did this all of the sudden. Hoping to get up and running very quickly because I have some orders to fill.


#2

We need your logs. Mostly the octoprint.log.


#3

Code

I tried, this is all I get. What is the correct command?


#4


#5

you have to edit it, not execute it. What's your ssh client in the screenshots? You can scp them (if you know how) or see a few lines at a time with nano [logfile] or pico [logfile] or vim [logfile] or less [logfile]. Hopefully you can get Octoprint running and just download the logfile from there.

In the future when sharing text-only output, just copy and paste the text rather than sharing a screenshot. Make sure to properly format the text so it's readable.


#6

octoprint.log (365.8 KB)

My Ender 3 instance is up. Does this help?


#7

The log definitely helps. I looked at the top and the bottom, realized it was long, so I then exited the file and masked out the INFO lines:

grep -v INFO octoprint.log

Saw the error fairly quickly, so then I went into the file, searched for the error to get the full context:

2019-03-05 21:44:35,919 - octoprint.plugin - ERROR - Error while calling plugin rgb_status
Traceback (most recent call last):
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/plugin/__init__.py", line 230, in call_plugin
    result = getattr(plugin, method)(*args, **kwargs)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_rgb_status/__init__.py", line 120, in on_after_startup
    self.init_strip()
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_rgb_status/__init__.py", line 111, in init_strip
    self.strip.begin()
  File "/home/pi/oprint/local/lib/python2.7/site-packages/rpi_ws281x/rpi_ws281x.py", line 124, in begin
    raise RuntimeError('ws2811_init failed with code {0} ({1})'.format(resp, str_resp))
RuntimeError: ws2811_init failed with code -13 (Unable to initialize SPI)

Disable the RGB plugin, I'm pretty sure that'll fix your problem. Looks like there's an issue at the author's plugin repo, the error is on your side, but the plugin should at least fail gracefully.


#8

That makes sense because I had installed that because it popped into my feed and then tried to print stuff and that's where it didn't work. You Sir, are a life saver. Thank you so much.


#9

Jordan, sorry for the inconvenience here! I've pushed an update to the RGB_status plugin that should stop this error from causing OctoPrint to crash.

This happens when you try to initialize the plugin if the pi user isn't in the gpio group. To fix the actual issue, you need to run sudo adduser pi gpio on your Raspberry Pi and reboot. All three of the OctoPi instances that I've used had pi user in the gpio group by default, but maybe there is (or was) a version of the image where that is not the case.

In regards to your suspicion about the undervoltage error, I highly suspect the board inside your printer (at least the Ender 3, not sure about the Rostock) is actually pulling power from the USB port on your Raspberry Pi which means a 2a power supply probably isn't enough.