Setting up a second camera

What is the problem?

Trying to get a second camera working on my octopi

What did you already try to solve it?

Followed this Setting up multiple webcams in OctoPi the right way and tried looking at some of the solutions in there but couldnt get the 8081 port to send an image

Have you tried running in safe mode?

no

This is the webcamd.log

Starting up webcamDaemon...

--- Configuration: ----------------------------
cfg_file: /boot/octopi.txt
camera: usb
usb options: -r 640x480 -f 10 -d /dev/v41/by-id/usb-GenesysLogic_Technology_Co.__Ltd._USB2.0_UVC_PC_Camera-video-index0
raspi options: -fps 10
http options: -w ./www-octopi -n

Explicitly USB device:

cfg_file: /boot/octopi.conf.d/webcam2.txt
camera: usb
usb options: -r 640x480 -f 10 -d /dev/v41/by-id/usb-SHENZHEN_AONI_ELECTRONIC_CO.__LTD_Full_HD_webcam_AN202011030002-video-index0
raspi options: -fps 10
http options: -w ./www-octopi -p 8081

Explicitly USB device:

Found video devices:
/dev/video0
/dev/video1
/dev/video10
/dev/video11
/dev/video12
/dev/video13
/dev/video14
/dev/video15
/dev/video16
/dev/video18
/dev/video2
/dev/video3
config file='/boot/octopi.txt':USB device was not set in options, start MJPG-streamer with the first found video device: /dev/video0
<13>Jul 18 22:51:04 root: Starting USB webcam
Checking for VL805 (Raspberry Pi 4)...

  • It seems that you don't have VL805 (Raspberry Pi 4).
    There should be no problems with USB (a.k.a. select() timeout)
    Running ./mjpg_streamer -o output_http.so -w ./www-octopi -n -i input_uvc.so -r 640x480 -f 10 -d /dev/v41/by-id/usb-GenesysLogic_Technology_Co.__Ltd._USB2.0_UVC_PC_Camera-video-index0 -d /dev/video0
    MJPG Streamer Version: git rev: 5554f42c352ecfa7edaec6fc51e507afce605a34
    i: Using V4L2 device.: /dev/video0
    i: Desired Resolution: 640 x 480
    i: Frames Per Second.: 10
    i: Format............: JPEG
    i: TV-Norm...........: DEFAULT
    Unable to set format: 1196444237 res: 640x480
    Init v4L2 failed !! exit fatal
    i: init_VideoIn failed
    Done bring up all configured video device

Goodbye...

Anything im missing information wise please let me know

You have a typo in your configuration. Where you have

usb options: -r 640x480 -f 10 -d /dev/v41/by-id/usb-GenesysLogic_Technology_Co.__Ltd._USB2.0_UVC_PC_Camera-video-index0

Instead of /dev/v41, with a number one, the path starts /dev/v4l with a lowercase letter L.

you solved it straight away thanks buddy, strange though as i just copied and pasted directly from the guide, oh well thanks again