Setting up Arducam

Camera model

Arducam ov5647

What is the problem?

Just got Octopi up and running, I'm not really a programmer, but I can cut/paste...

There's a lot of convoluted guides on how to setup the Arducam, so I may have done something wrong. When I run 'libcamera-hello', it pushes out a bunch of lines of text (I assume, the image...), so I think the hardware itself is working.

When I view on Octoprint it says the webstream wasn't loaded. I've tried going to :8080 and it says refused connection...

What did you already try to solve it?

various things. Last was 'sudo service webcamd start'

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (46.0 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

8gb Rpi 4 B
Ender 3 S1 Pro
I have amazing hair

There are currently two OctoPi images available which have very different support for cameras. It appears that you have installed the one with the older camera support and that one doesn't support the Arducam "out of the box". There are instructions on how to add support on the Arducam website and in numerous topics in this forum.

Instead of going that route, installing the OctoPi image with the new camera stack includes support for the Arducam and you should only need to edit a configuration file or two. There are also topics in the forum with instructions as well.

I don't own one of these cameras (I have an RPI Camera V3) so my answer is a bit vague but it should get you pointed in the right direction.

Thanks, B!

Yeah - I loaded the 'stable' release of OctoPi using the RPi imager. Being new to the game, I figure stable is good. Giving a go this morning with the new camera stack version!

Heyyyy! That was it!! Thanks, B!!

And then followed these instructions to get ArduCam Focus to work - GitHub - moof-src/ArduCamFocus: repository for ArduCamFocus octoprint plugin. Control an ArduCam focus from octoprint on an octopi.