Setting up OctoPrint on a Raspberry Pi running Raspberry Pi OS (Debian)

Thank you so much for these detailed, accurate and thoughtful instructions, and for this great software! I appreciate the mentions of various security concerns and how to address them. Everything worked 100% as described for me, including webcam, with a fresh installation of Raspberry Pi OS on a Pi 4. I'm waiting for my printer to arrive today but as far as these instructions, these are spot on.

To me using a full installation of the OS is much preferable to OctoPi (not that I have tried it that way), especially with a Pi that has some performance left over for other tasks like a 4. Great to be able to ssh or VNC in and use it as a computer.

1 Like

this solved all my problems... thank you!!! That webcamDaemon script broke my stream everytime.

Hello everyone!

I somehow missed a step and I do not have webcamd.service setup in my /etc/systemd/system folder. Attempting to run a mkdir and creating this file resulted in a "mkdir: cannot create directory '/etc/systemd/system/webcamd.service': Permission denied"

Any suggestions? When manually turning on the webcam server, and inputting the http://:8080/?action=stream command, I am able to view the webcam. Hopefully this enough info to get some more experienced folk of what my current setup state is. but if more info is needed, happy to share wtv is needed. Thanks in advance!

webcamd.service is not a directory, so you shouldn't be creating it with mkdir. It probably needs sudo to create & edit that file, so to edit it you would use something like nano. For example:

sudo nano /etc/systemd/system/webcamd.service
1 Like


I installed Debian 11 on an old ASUS Eee PC 105D and then Octoprint on top of this, following this instructions. In Debian 11, there is already haproxy 2.x and it is mentioned in ths article, that there should be an example for a config file that fits this version (Reverse proxy configuration examples). But I can't find it. Can someone show it to me?

Best regards

If you scroll right to the bottom of the comments on that thread, there should be one detailing the changes:

It should probably be merged into the top post as a separate config.

Thank you! The sudo nano command worked :slight_smile:

I tried this code on a Raspbian (bullseye) fresh install and it won't work because the git command doesn't exist.

The sudo apt install part of the code installs subversion, is that really necessary? I think there is a mistake, it should be git instead of subversion.

Entirely possible, seems logical to me to change it. Probably no one has noticed because the OctoPrint install instructions have it on the list to install, though it's not actually required there anymore since OctoPrint is on PyPi.

so i really need help here. i know my way around windows but have never messed with linux. i understand it but just cant figure out a few steps. i have octoprint installed and tested its working. i managed to get mjpg streamer running with my cam. now im stuck on getting them both to start on boot. the issue im running into is
"Create a new file at /home/pi/scripts/webcamDaemon (ie. run nano /home/pi/scripts/webcamDaemon ), with the following content:"

i tried "nano /home/pi/scripts/webcamDaemon" but i just recieve command not found. i can ftp to the server so if someone can just give me the script and i can place it where it needs to go. i apologize. ive tried multiple times now and i made this account only for the purpose of getting help with this, if it helps im running a jetson nano 4gb.

edit:so after looking nano is just a text editor. can i just make a text file on windows and ftp it to the server? but also the directories do not exist at this point, should the already be there? or is it normal i have to create them for this step

What Linux distro are you running? You might be able to install nano. Or use another text editor - it doesn't have to be nano. Any way you can get the files across to the Pi will do, ftp is fine. I would recommend finding a text editor you can use in case you need to edit or correct files in the future, even if you can get through this guide by just copying the files across.

so i got the files across now im just running into a host of issues. when attempting to run

./mjpg_streamer -i "./" -o "./"

the only output i get is " -bash: ./mjpg-streamer: Is a directory"

i just cannot get the cam to start anymore and defintetely does not start on boot. following a different guide i had it working through a test command but with this guide im getting nothing from my cam. im running the distro from nvidia for the jetson, its L4T. havent had a single issue yet other than getting this webcam to start.

In the previous step of the guide, it had cd mjpg-streamer/mjpg-streamer-experimental first, so you will need to do that again.

It might be easiest for you to open your own topic for your specific problems that will take more conversation - it can get confusing with lots of posts under the guide.

ok. thanks. probably just done with it at this point. beyond frustrating. not paying $160 for a pi just to run octoprint, cant get it to work on the jetson. yup. back to sd printing for me. sorry im just angry. i have friends i would consider computer illiterate or straight up idiots and they have gotten this running. not sure what the hell my problem is..

Well, if you decide to continue pursuing installing OctoPrint, you know where you can get help :wink:

Are pi's ridiculously priced everywhere? Cheapest I can find is $165 CAD for a pi4 b. And also not sure how much work it takes but willing to pay someone to put together an octoprint image for a jetson nano.. thanks for the help. Apologies for being a grumpy ass today.

When doing a manual install there is no octopi-wpa-supplicant.txt to edit the WiFi and I need to do it on the ssh system do any of you super smart people no how I can do it I'm using Ubuntu server and followed all the instructions on here to set it up and everything works great if I'm hard wired to my router but not WiFi

I'm sure there are how to's on setting up WiFi on whatever your base OS is on the RPi. Any instructions or files that start with "octopi-" are going to be specific to OctoPi as the base.

These are the instructions for setting up octoprint on other devices and there is no mention of how to set WiFi for the other devices.
These are not for octopi that's easy to setup on a raspberry pi but don't work for orange pi running Ubuntu but cheers for response

You won't find that answer on the community forums for OctoPrint - its an OS specific instruction that is outside OctoPrint.

The guide for installing Ubuntu on a Raspberry Pi has instructions: How to install Ubuntu Server on your Raspberry Pi | Ubuntu

I assume you should be able to find wherever you got the Ubuntu image from will have instructions on how to use it. This guide only details how to install OctoPrint on to an already working Linux device.