Setup Help for "Streamer" Plugin

What is the problem?

I'm trying to install the "OctoPrint-WebcamStreamer" plugin and set it up to stream on Twitch. That part seems to be configured but I'm struggling with the Docker part of the installation and getting two different errors.

Within OctoPrint i get the following:
"WebcamStreamer Error
404 Client Error: Not Found ("pull access denied for adilinden/rpi-ffmpeg, repository does not exist or may require 'docker login': denied: requested access to the resource is denied")"

While in SSH when trying to pull the docker image I get the following
"pi@octopi:~ $ docker pull adilinden/rpi-stream:latest
Error response from daemon: pull access denied for adilinden/rpi-stream, repository does not exist or may require 'docker login': denied: requested access to the resource is denied"

What did you already try to solve it?

I've tried to reinstall the plugin by reinstalling the Docker as per the instructions via SSH but getting the following error from that

Have you tried running in safe mode and if so did it solve the issue?

No, not sure how to do this.

Complete Logs

octoprint.log - octoprint.log (863.3 KB)
serial.log - serial.log (296 Bytes)

Additional information about your setup

OctoPrint version: 1.4.2
OctoPi version: 0.17.0
Printer: Ender 3 Pro

others seem to have the same problem and @adilinden said a month ago

I currently do not have a working 3D printer due to ongoing renovations. Means I am in no position to actually test anything. If there are willing participants that would like to continue development, I would welcome additional maintainers.

You could try this plugin in the meanwhile

Thanks, will try that one and see how i get on.

Seem to be clear with that one but still having some issues (which i assume is just me being stupid).
Run the docker and installation and getting the following message during the test process.

pi@octopi:~/rtmpstreamer $ docker run --privileged --name RTMPStreamer -ti octoprint/rtmpstreamer:latest 640x480 5 rtmp:// null
OctoPrint Webcam Stream:
Stream Resolution: 640x480
Framerate 5
Stream URL posting to: rtmp://
ffmpeg version N-90990-g652b857b94 Copyright (c) 2000-2018 the FFmpeg developers
built with gcc 6.3.0 (Raspbian 6.3.0-18+rpi1+deb9u1) 20170516
configuration: --arch=armel --target-os=linux --enable-gpl --enable-omx --enable-omx-rpi --enable-nonfree
libavutil 56. 18.100 / 56. 18.100
libavcodec 58. 19.101 / 58. 19.101
libavformat 58. 13.101 / 58. 13.101
libavdevice 58. 4.100 / 58. 4.100
libavfilter 7. 21.100 / 7. 21.100
libswscale 5. 2.100 / 5. 2.100
libswresample 3. 2.100 / 3. 2.100
libpostproc 55. 2.100 / 55. 2.100
[tcp @ 0x2440710] Connection to tcp:// failed: No route to host No route to host

And the attached error in the Octoprint app.