Sever not starting on OSX

What is the problem?
I just followed the install guide Wiki for OctoPrint on Mac. When I try to run the server with the command octoprint serve I get back an error: [Errno 48] Address already in use. I get a 404 error when I try to open the webUI at localhost:5000 or octopi.local. I think that the server isn't starting.

What did you already try to solve it?
I've looked through all the ports in use on the relevant IP with lsof -i, confrimed that the server did not start up. I've re-installed python 2.7 with brew, and reinstalled octoprint.

Logs from the terminal
(venv) Nathans-iMac:OctoPrint nathan$ octoprint serve
2019-11-12 16:02:59,937 - octoprint.startup - INFO - ******************************************************************************
2019-11-12 16:02:59,938 - octoprint.startup - INFO - Starting OctoPrint 1.3.12
2019-11-12 16:02:59,938 - octoprint.startup - INFO - ******************************************************************************
2019-11-12 16:02:59,948 - octoprint.plugin.core - INFO - Loading plugins from /Users/nathan/OctoPrint/venv/lib/python2.7/site-packages/OctoPrint-1.3.12-py2.7.egg/octoprint/plugins, /Users/nathan/Library/Application Support/OctoPrint/plugins and installed plugin packages...
2019-11-12 16:03:00,387 - octoprint.plugin.core - INFO - Plugin Pi Support Plugin did not pass check, not loading.
2019-11-12 16:03:00,433 - octoprint.plugins.octoprint.plugins.discovery - INFO - pybonjour is not installed, Zeroconf Discovery won't be available
2019-11-12 16:03:00,439 - octoprint.plugin.core - INFO - Found 14 plugin(s) providing 14 mixin implementations, 22 hook handlers
2019-11-12 16:03:00,455 - octoprint.server.heartbeat - INFO - Starting server heartbeat, 900.0s interval
2019-11-12 16:03:00,478 - octoprint.cli.server - ERROR - Uncaught exception
Traceback (most recent call last):
File "/Users/nathan/OctoPrint/venv/bin/octoprint", line 11, in
load_entry_point('OctoPrint==1.3.12', 'console_scripts', 'octoprint')()
File "/Users/nathan/OctoPrint/venv/lib/python2.7/site-packages/OctoPrint-1.3.12-py2.7.egg/octoprint/init.py", line 609, in main
octo(args=args, prog_name="octoprint", auto_envvar_prefix="OCTOPRINT")
File "/Users/nathan/OctoPrint/venv/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/core.py", line 764, in call
return self.main(*args, **kwargs)
File "/Users/nathan/OctoPrint/venv/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/core.py", line 717, in main
rv = self.invoke(ctx)
File "/Users/nathan/OctoPrint/venv/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/core.py", line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File "/Users/nathan/OctoPrint/venv/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/core.py", line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File "/Users/nathan/OctoPrint/venv/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/core.py", line 555, in invoke
return callback(*args, **kwargs)
File "/Users/nathan/OctoPrint/venv/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/decorators.py", line 17, in new_func
return f(get_current_context(), *args, **kwargs)
File "/Users/nathan/OctoPrint/venv/lib/python2.7/site-packages/OctoPrint-1.3.12-py2.7.egg/octoprint/cli/server.py", line 206, in serve_command
ignore_blacklist)
File "/Users/nathan/OctoPrint/venv/lib/python2.7/site-packages/OctoPrint-1.3.12-py2.7.egg/octoprint/cli/server.py", line 118, in run_server
octoprint_server.run()
File "/Users/nathan/OctoPrint/venv/lib/python2.7/site-packages/OctoPrint-1.3.12-py2.7.egg/octoprint/server/init.py", line 281, in run
self._start_intermediary_server()
File "/Users/nathan/OctoPrint/venv/lib/python2.7/site-packages/OctoPrint-1.3.12-py2.7.egg/octoprint/server/init.py", line 1751, in _start_intermediary_server
self._intermediary_server.server_bind()
File "/usr/local/Cellar/python@2/2.7.17/Frameworks/Python.framework/Versions/2.7/lib/python2.7/BaseHTTPServer.py", line 108, in server_bind
SocketServer.TCPServer.server_bind(self)
File "/usr/local/Cellar/python@2/2.7.17/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 434, in server_bind
self.socket.bind(self.server_address)
File "/usr/local/Cellar/python@2/2.7.17/Frameworks/Python.framework/Versions/2.7/lib/python2.7/socket.py", line 228, in meth
return getattr(self._sock,name)(*args)
error: [Errno 48] Address already in use

Sounds like something is already using port 5000, I'd guess.

netstat -ant | grep LISTEN

Ran netstat, there was something on port 5000. I just tried a handful of other ports that were free, in the config file port option, but the terminal returns the same error.

Were these ports also in use after the error when running netstat?