Simplify 3D and Octoprint


#1

Hi, my Gcode View is crazy:

With Cura i dont have any problem. In Simplify 3D if i change "origin offset", "home directorion" and "toolhead offsets" printing fail... print not start in real offset.

Homing direction "min" for X-Axis and Y-Axis, and "origin offset" is 0 for X and Y-axis. Octoprint 1.3.9 whit TH3DStudio Firmware.

Any suggestion? Thanks.


#2

Check the printer profile for the correct Origin:

35%20PM


#3

Thanks, but this config is set in Simplify3d:

![12|682x500]


#4

And in profile:


#5

In OctoPrint's Terminal tab:

G28

The printer should attempt to HOME all motors X/Y/Z. Presumably, you expect the assembly to move to the left/rear of the printer.

G90

Set the positioning to absolute mode. Any commands after this will be absolute coordinates.

G0 X100 Y100

You're hoping that the assembly moves right by 100mm and forward by 100mm.

If all this produces the expected results, then your OctoPrint and its profile is happy. (It's entirely possible that you didn't home the motors before sending the job, btw.)

I don't know Simplify 3D but I'd guess that it's set correctly.


Take 2: You didn't mention whether or not that both of these are true 1) you have a dual extruder printer and 2) you're attempting to print from the 2nd extruder. If so and your extruder offset is wrong then it might behave like this.


#6

I'm pretty sure the problem is in your settings for the printer in OctoPrint, not Simplify3D, which is what is causing the GCode visualizer to be confused. If that's the case, @OutsourcedGuru has the right solution for your problem with the GCode viewer, since it believes your origin is the center of the bed. Not sure why it's ok with Cura; does it print properly if you use Cura, too? I use S3D extensively, and your settings there should put the origin in the right place. Your question doesn't say it prints wrong, just that it is visualized wrong, so that's why we're telling you to make OctoPrint's settings match S3D's.