Slicer ignores preswitchextruder.gcode=


#1

What is the problem?
I'm using a second extruder for supports.
This seems to work.
But I need to add some pre- and post-switch gcode to optimize the process.
My profile has:
preswitchextruder.gcode =
G91
G1 E-15 F300
G90
postswitchextruder.gcode =
G91
G1 E15 F300
G90

But the generated gcode still says:
;Switch between the current extruder and the next extruder, when printing with multiple extruders.
;This code is added before the T(n)

T1
;Switch between the current extruder and the next extruder, when printing with multiple extruders.
;This code is added after the T(n)

Looks like these settings are not used.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

OctoPrint** : 1.3.9


#2

Did you restart OctoPrint after making the changes?


#3

For other profile related settings, just uploading and reslicing works just fine.
But since I re-tested after upgrading OctoPrint, I can say, that I have actually.
Did not matter.


#4

Do your changes persist in the Settings area, having restarted?


#5

I'm not experiencing any other problems with my settings.
Even if I change something in the same profile (.ini) then these changes do work, like temperature, which is very visible when heating up before printing.


#6

So when you go back to Settings -> Gcode, you see the changes you made earlier?


#7

OMG.. there is a section for these parameters.. that's crazy.
I was editing them in the .ini file as mentioned.
Thought they would change along with all the other settings when I select a slicer profile.
Never mind then.
Thanks.


#8

If it's fixed, make sure to click that icon to indicate so.