Slicing doesn't work


#1

What is the problem?
When I download file .stl and I click on "slice", I have a error "WindowsError: [Error 193] %1 is not a valid Win32 application" in the terminal.
And the download bar loads to infinity 0%.

What did you already try to solve it?
Nothing, I don't know what I can try to do to solve my issue.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Octoprint 1.3.6; google chrome, w10


#2

It looks like you are trying to use a Linux slicer on a Windows system.


#3

Hi !
Thank you for your answer. How can I install a windows slicer?


#4

I have no idea, I am using Linux only. IMHO Windows is for gambling only, not for serious work.


#5

oh ok, thank you for your answer


#6

Slice with a good computer...RPi has very limited memory and processing power...upload the gcode thru the web interface...MUCH faster and easier


#7

Currently, I am on W10 not RPI
So I don't understand your comment :confused:


#8

Are you trying to use octoprint to print on your printer

Are you trying to slice a .stl to gcode on your W10 computer?
If so then download CURA 3.2.1 windows version to make gcode


#9

Hi!

Yes I'm trying to slice a.stl to gcode on w10.
I thought you needed a version higher than 15 but I misread.


#10

I try with Cura 3.2.1.


#11

Hi!

With Cura 3.2.1 I have the same error :confused:
I don't understand why


#12

It's completely unclear at least to me as to what you are actually attempting to do here. Use Cura 3.2.1 from within OctoPrint? Won't work, unsupported version. Use stand alone Cura to slice something? Best ask Cura support then why it's not working.

You also keep pasting this error up there but it's completely unclear from where that originates, and on top of things it's truncated. %1 also looks like something with a placeholder was configured as a run command somewhere and Python rightfully complained about that not being an application.

So let's start from the beginning. Tell us what you are trying to do here. What you have done to achieve that (include screenshots). What issues you are running in.

So far that's all completely unclear. "Slicing doesn't work" and that error can mean ANYTHING. We don't know what you did, we can't see your screen, we can't look over your shoulder and tell you what's wrong.


#13

Yes sorry it's confused.

I would like to slice a file .stl with Octprint.
When I try to slice, it charges endlessly.

I have an another file created.
And I have this message in my terminal:

I'm on w10, I'm using Octoprint 1.3.6 and Cura 3.2.1


#14

What do you have configured under Settings > CuraEngine (<= 15.04) > Path to CuraEngine?


#15

My path is:
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Ultimaker Cura\Ultimaker Cura 3.2.1.lnk


#16

Yeah, that won't work. First of all you need to use the path to CuraEngine, not the Cura desktop program. Secondly you need to use the path to the exe, not a shortcut. And thirdly you need to use CuraEngine 15.04.

Mind if I ask why you want to slice through OctoPrint in the first place when you are running it on a server that is capable of running a full fledged Cura to begin with which is WAY more user friendly than the built-in slicing?


#17

I would like to slice through Octoprint because at the end of my project, I will be on raspberry and I will have only Octoprint


#18

Ok. Personally I think it would be easier to use OctoPi now instead of jumping through the hoops of settings stuff up under Windows when you plan to switch to a Pi later on anyhow, but you'll prolly have a reason for that.

Go here:

https://ultimaker.com/en/products/cura-software/list

Scroll down to where it says "Version: 15.04.6". Download and install that. Open the installation folder (probably something like C:\Program Files (x86)\Cura_15.04.6), there's a CuraEngine.exe in there. That's whose path you'll need to enter into your Cura Engine plugin settings, so probably something like C:\Program Files (x86)\Cura_15.04.6\CuraEngine.exe. Click the "Test" button to verify that it's actually the right path.


#19

I would second Gina's recommendation that if you are going to end up slicing on the Pi, you just set up for that now, rather than starting one way and switching later on.

Reading between the lines of the posts here, I suspect that since you did not have Cura version 15.04.x installed on your Windows machine, then you probably did not create a filament/slicing profile, export it from windows and import it into OctoPrint. That is a necessary step, since OctoPrint needs those settings in order to slice, and those settings are what the Full Featured Slicer plugin uses as its starting point.


#20

It is for a project, I must use a Raspberry.
I had the Cura 15.04.6 and I tried with this version before my request, but it didn't work.
Now it works, I don't know what I didn't do right.
Thank you Foosel !