Slow uploading of .gcode files


#1

When uploading .gcode files from my PC, upload takes couple minutes (uploading to OctoPi, not to SD Card)

Latest OctoPi, printer Creality Ender 3, browser Google Chrome, file is 2.1Mb size


#2

Guys ? Please, help me


#3

Hi @filimonic!

What Pi? and what network connection?
If WiFi, try LAN.


#4

I have exactly the same problem, I'm using Wi-Fi but that shouldn't be a problem because I don't have any problem using real time streaming.

My octoprint was working properly however suddenly it takes "years" to upload a file -Just kidding but it's really slow-

It took between 15 or 20 minutes to upoload a 2MB gcode file


#5

Hello @Cesar_Arguello! Got some log files?


#6

Not right now because I deleted all my preview Jobs and logs trying to solve the problem. I'm going to upload a new file and wait for new logs


#7

Remembers me to a situation I had months ago ... finally it was a slowly "dying" sd-card in the raspi.
No real idea if sd-cards can get fragmented over the time, but using a fresh installed card and all was fine again!


#8

I've had an intermittent problem myself which began perhaps three months ago. Once in a while doing things with the Files side panel widget would take forever.

I mention what I did here and here.

I spend more time coding to OctoPrint now than I do actually printing but I think that I've solved my own printer's problem (75% certainty). I'm guessing that the fix is in that first link: I turned off IPv6 on my printer.


#9

I had the same problem in a previous version so I replaced the SD card with a new one, but this change din´t help at all so I reinstalled octoprint.


#10

Mine one was the wifi problem.
I noticed speed slows down when I upload only.
If I download, speed is ok.
So I uploaded big file and tested uploadin while downloading this big file. It speeds up significantly while transfer from octoprint to pc is in progress.


#11

Well there´s something interesting, If I try to transfer a file using the Octoprint gcode uploader o even if I try to copy a file using SCP the process last forever, however if I try to download a file from Internet using wget command directly on the raspberry there is no problem actually the OS uses all the bandwidth available


#12

This is the log file, but this looks like an OS related problem

octoprint.log.zip (411.5 KB)

=========six hours later=========

Holy Molly!
I've doing several troubleshooting I plugged in an Ethernet cable and all the files were uploaded quickly, but now I unplugged the Ethernet cable and magically I can upload files fast even using the wi-fi :expressionless:

=========Update 2019-02-20 06:12:00 GMT=========
After some prints and file uploads the upload speed is so freaking slow, so I replaced my raspberry pi3 with a raspberry pi 3+ in order to leverage the 5Ghz Wi-fi. Maybe this will help


#13

it happens when you have uploaded too much code files.
When you clean the folder it is fast again.
It came up month before.
Gina said it is because of how octoprint reads the files.
Changing that would be good, but many things then have to rewritten ....


#14

Nope. If things are slow when just scping files over, OctoPrint isn't even involved and this is a problem purely on the network layer.


#15

ah ok there it looks like the connection is the problem / on my py it was octoprint :smiley: the upload took 1s and then it last 30s to 1 minute when the file showed up in the GUI