SmartPreheat not preheating both

Smart Preheat is not heating both...do I need to change my printer config in my slicer to add anything?

What version is installed?

I installed and it immediately said update so I did v2 I think.

I thought it monitored the code and inserted itself, do I need to change my slicer pre print settings?

v0.0.3 was released today which fixed a few parsing bugs. Try refreshing and updating to that and see what happens.

As long as your gcode file specifies temps for each heater it should work.

314/5000

Hello, I also have the same problem, I use Cura as a laminator, and the plugin does not do what is expected. It is version v0.0.3
My gcode header looks like this:
M190 S35
M105
M140 S60
M104 S200
M105
M109 S200
M82; absolute extrusion mode
G21; metric values

Should I change something ?, or is the plugin supposed to read the values and send

Captura de pantalla de 2020-05-08 01-23-52

@diaber did you insert the snippet into your octoprint gcode script?

You might want to add a button in settings...."Add to GCODE scripts".

@jneilliii I don't want to make an assumption of where it should be inserted. Though a wizard could be a good way to inform.

I deleted my rubbish...

@Ewald_Ikemann Sorry not following what you are suggesting? Is this related to the topic?

Seems I missed the point... better say: The start of the thread :blush:

820/5000

Hello, I do not know where I should insert the code, and what is the code to insert, I have not seen much more information, it may have been passed.
If I go into plugin settings in Octoprint it says "Insert the following into any GCODE Script:"
it then appears in red:
{% snippet 'doSmartPreheat'%}
and inside an editable window more code appears:
; Wait for bed to reach 80% of required temp then set to required temp
{% if printer_profile.heatedBed%}
M190 S {{(plugins.smartpreheat.bed * 0.8) | round}}
...

Which one should i use? Or are they both?
if I insert the code in red, inside the gcode file to print, it does nothing, if I insert the code that appears inside the editable window, it gives error.
I guess I'm not putting it where I should, or it's just not putting it in that file.

Thank you

Likely

Settings -> GCODE Scripts -> "Before print job starts"

Thank you very much, now it works fine,

Greetings

I have the same issue. Version 0.0.4 is "installed". Does installing the plugin supposed to make Octoprint do anything or is it required to copy the starting script to Settings -> GCODE Scripts -> "Before print job starts"?
It is not clear to me how this plugin is supposed to be installed.

is it required to copy the starting script to Settings -> GCODE Scripts -> "Before print job starts"?

Yes