[SOLVED] After update to 1.4.1, files list is not updating after any operation

What is the problem?

Updated to 1.4.1 today and now the files list is not updating after any file operation. I browse to any folder, upload a file and it never shows up even though it acts like it uploaded. I try the refresh button, in Octoprint itself, still doesn't show. I manually refresh the webpage (chrome) and navigate to the folder and it's there. Same thing with all file operations...deletions, adding folders..etc. They don't show up until after I manually refresh the browser.

What did you already try to solve it?

Tried it on several browsers, not limited to chrome. Also the case on Opera.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Octoprint.log is too large to post in this message, and I don't see a way to attach, so I'll try to share a link and upload to dropbox.

Try getting a copy here:

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I just updated to 1.4.1 today when I loaded up the server and got the notification. This didn't start until after I updated to 1.4.1.
OS is Windows 10 Home
Chrome and Opera
Running on a RPI 3B, connected to Prusa MK3S

You might want to tack onto this issue ticket.

I've narrowed down this issue to the GCode Editor plugin. Disable that plugin and everything will work as expected. Relative issue on GCode Editor plugin repository has been opened here.


I hope this is not noise, but I accidentally disabled the GCode Viewer rather than GCode Editor and that seemed to fix the problem in my setup.

OMG...that was it! THANK YOU!!! Man, I was really not looking forward to reinstalling from scratch, getting Filament manager plugin to work was such a pain in the *ss. It never dawned on me that another plugin could wreck a builtin Octoprint functionality, lesson learned. I guess in the future, I will systematically disable add-ons one at a time to eliminate them as culprits.

Thanks again!!! You rock!!

For the record, this is precisely why a) safe mode exists and why b) you should always check if an issue persist in safe mode before opening tickets/panicking/cursing me and my family. More often than not the issue is actually with a third party plugin, not core OctoPrint.


Duly noted! Thanks again! And I'd never curse you or your family :stuck_out_tongue: