[Solved] Cannnot connect Octoprint to printer

#1

What is the problem?
When I press "connect" in the Octoprint web page, it says "connecting" for a while and then returns to "offline."

What did you already try to solve it?

  • Lowering baud rate
  • Reboot in safe mode
  • Disable automatic firmware detection
  • Disable blacklist
  • Restart octoprint
  • Restart web page
  • A fair amount of googling

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
OctoPrint v. 1.3.11 running on Orange Pi Zero (Armbian latest version)
Printer: Anycubic i3 Mega
Printer fw: v1.1.0

Terminal:

Connecting to: /dev/ttyUSB0Changing monitoring state from "Offline" to "Opening serial port"Connected to: Serial<id=0xb14eccb0, open=True>(port='/dev/ttyUSB0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitorChanging monitoring state from "Opening serial port" to "Connecting"Send: N0 M110 N0125Recv: �Np|�_HH5�P��JpON6��Z�zRecv: %�h�on\x0cm7�nn\x19|&~�h&�H�X�J\x13\x03�~�A\x0c\x086�M�7��-\x0c\x07*&�]\x03\x0bMbO6\x17d6�p|��H\x13H6f�J�JJ�8J�(K�J?JKp|~H\x0f^\x17l**\x07J�Z��I��I�k\x08�HJp|~\x18�\x0b^>h�$p|\x084\x08�A\x08�J\x08�J�%�X�\x1a�\x0b^>Y�N66\x0b�^^aHM�6�p|\x084\x08�AHJ�AHJ�AHJp|@_a�&&��$M\x0fM6\x03lI$M^\x0bj�6\x03lI�6X\x0f\x0bH>\x03�4�&('�hI�&(n~lI�&\x18n~lX�J�Z�I�j\x08�J�(%�8%�(�J_�X��Mah\x04\x07J�J�I�j\x08N�X��\x0b�N6�\x0bh$p|\x08�Recv: N�X�:6\x136l6N&\x1b^f�J�[�(%\x08\x08M0�[�(J\x08-H\x07Recv: \x16jO6�f�J�Z�5hE.�\x08[�f�There was a timeout while trying to connect to the printerChanging monitoring state from "Connecting" to "Offline"Connection closed, closing down monitor

Octoprint log: octoprint.log (187.9 KB)

Note: I had Octoprint running fine on basically the same setup before, but had wifi issues with my Orange Pi Zero. I have replaced with another OP Zero and re-installed.

regards,
Sean

#2

Sounds like this.

Try 115200 baud but get the custom firmware version of that from the manufacturer to test it.

#3

Thanks, Guru.

It does automatically set the baud rate (115200), and I have also tried running at that way. Also, as I said, it used to work before on this firmware. I'll have a look at the new fw and give it a try, though.

cheers,
Sean

#4

ah, it looks like you are right -- manually setting the baudrate to 250000 solves the issue.

thanks,
Sean