[Solved] Download on homepage seems to be corrupted

Download the 0.16.0 ISO from the OctoPrint homepage and tried to burn the image onto the SD card with Etcher. Etcher reported that the ISO is corrupted, I tried to download for a few more times and the problem persists. Checked MD5 and it does not match. Any other ways that I can try to download the image?

Thanks a lot!

You could try the new OctoPi 0.17.0 RC1 (it's like a beta test)

For the record, freshly downloaded myself:

$ md5sum octopi-stretch-lite-0.16.0.zip
c363d50f80f04bebcdc774ec20ad22ce *octopi-stretch-lite-0.16.0.zip

MD5Sum published on download page:

MD5Sum of the .zip: c363d50f80f04bebcdc774ec20ad22ce

Image on the server:

$ md5sum octopi-stretch-lite-0.16.0.zip
c363d50f80f04bebcdc774ec20ad22ce  octopi-stretch-lite-0.16.0.zip

Unzipped, tried to flash via Etcher, flashes just fine and contains what it should. Nothing corrupted.

Make sure your browser or anything else between you and the download server isn't trying to be helpful by unzipping things for you.


Problem solved, try not to use either a Mac or Safari browser to download, they really suck. Anyways my OctoPi is up and running. Thanks everyone!

1 Like