[solved] Newest Pi Kernel 1.20210831-1 causing Perimeter Blobs

Platform: OctoPrint on Pi 4 (may have same issue on other pi boards but I don't have them to test)

Printer: Ender 6 (issue may be present on other printers also)

Issue: Perimeter blobs after doing apt update/upgrade and rebooting to newest kernel

Logs: Nothing useful that I could find

Tests completed:
Sliced via Cura > Blobs
Sliced via Prusaslicer > Blobs
With/Without Arc Welder > Blobs
Safe mode > Blobs
4 Different STL's > Blobs
Changing different perimeter settings > Blobs
Changed Micro USB Cable > Blobs
Swapped to a new Pi 4 board > Blobs
Printed from SD Card > OK
All above tested on current versions of Creality, TH3d, and InsanityAutomation firmware builds

Solution: Downgrade 7 packages and reboot

List of packages: (you can check what version you have installed by doing "dpkg --list |grep raspberrypi-kernel")
libraspberrypi-bin:armhf (1.20210831-1)
libraspberrypi-dev:armhf (1.20210831-1)
libraspberrypi-doc:armhf (1.20210831-1)
linux-libc-dev:armhf (1.20210831-1)
raspberrypi-kernel:armhf (1.20210831-1)
raspberrypi-bootloader:armhf (1.20210831-1)
libraspberrypi0:armhf (1.20210831-1)

Version 1.20210805-1 of these packages can be downloaded and then installed/downgraded with dpkg -i from here > Index of /debian/pool/main/r/raspberrypi-firmware

Hopefully this will save someone else from the 5 day headache I had

OctoPi 0.18.0
OctoPrint 1.6.1

1 Like

Hello @notfixingit !

Please share them anyhow.

We also don't know what OctoPi version, what OctoPrint version.

This also was requested in the template you partially deleted.

Unfortunately I didn't even think about posting here until after I cleaned everything up from troubleshooting and because I never saw anything of value in the logs I didn't keep them when I cleaned.

As for the template, technically I deleted it all lol, I copy/pasted my notes over top of it, my bad, next time I'll use it.

Added versions to the first post

Throwing away my 30+ failed test prints today I did notice something odd that didn't catch my attention before, the blobs only happened on curved area's of prints.

After I get caught up on my backlogged prints from being down for almost 5 days, I might try upgrading the kernel again and doing a test print so I can get those logs for you @Ewald_Ikemann assuming no one else runs into this first.

There were people that mentioned in Discord that they are running the newer kernel without issue, even with 2 OctoPrint instances printing simultaneously, streaming two cameras, and taking snapshots for timelapses.

@jneilliii Any idea if they have a different printer, different model pi and what exact version kernel?

Ps which discord channel? Love to compare notes

That was me, and I have 2 ender 3s (one pro, one v2). The pi is a raspberry pi 4B 4gb, and I'm using the new kernel, bootloader, etc you mentioned above:

taylor@printerpi:~ $ dpkg --list |grep raspberrypi-kernel
ii  raspberrypi-kernel                   1:1.20210831-1                          armhf        Raspberry Pi bootloader

Also, the discord is the official OctoPrint discord...it's at the top of your screen as you read this!


@TTalkington thank you! I'm on the server, just didn't know what channel it was being talked about on. If you don't mind, can I hit you up on discord? Looks like our setup is the same excluding the printer model.

I should be caught up tomorrow on prints, so I can upgrade again and run some additional tests this weekend.

Sure, I'm The-EG on discord.

For another reference point, I needed to test something else out today, so I ran another set of concurrent prints. Both printers printing at the same time, running timelapses (snapshots every 30 seconds, one picam, one USB camera):

There are a couple of blobs on the grey piece, but considering it's PETG (orange is PLA+) and that printer uses a 0.6mm nozzle instead of a 0.4mm, I'm pretty sure it's more to do with hitting the limits of the filament/nozzle than an IO issue. I'm actually surprised it did the full 80 degree overhang, the entire arm/arc was wobbling a bit as it printed that high up :smiley:.
If the kernel update is causing some sort of IO issue I don't think I'm seeing it on mine.

Yeah that's very different than what I was experiencing, I should have thought to include a photo before!

That looks like the nozzle was pausing for a bit causing those. As large as they are I would suspect for a noticeable period of time while the printing was printing.

Sow now: Any logs?

@Ewald_Ikemann yep, finally had time.

Covers both prints, the python tornado error is with spoolmanager, safe to ignore
octoprint.log (473.9 KB)

With 1.20210805-1 packages, perfect
serial.goodprint.log (3.5 MB)

With 1.20210831-1 packages, blobs
serial.badprint.log (3.6 MB)

Updates to the packages referenced here are available. The version is the same, but the patch level has been incremented (1->3):

taylor@printerpi:/var/log $ dpkg --list |grep 1:1.20210831
ii  libraspberrypi-bin                   1:1.20210831-3~buster                   armhf        Miscellaneous Raspberry Pi utilities
ii  libraspberrypi-dev                   1:1.20210831-3~buster                   armhf        EGL/GLES/OpenVG/etc. libraries for the Raspberry Pi's VideoCore IV (headers)
ii  libraspberrypi-doc                   1:1.20210831-3~buster                   armhf        EGL/GLES/OpenVG/etc. libraries for the Raspberry Pi's VideoCore IV (headers)
ii  libraspberrypi0                      1:1.20210831-3~buster                   armhf        EGL/GLES/OpenVG/etc. libraries for the Raspberry Pi's VideoCore IV
ii  linux-libc-dev:armhf                 1:1.20210831-3~buster                   armhf        Linux support headers for userspace development
ii  raspberrypi-bootloader               1:1.20210831-3~buster                   armhf        Raspberry Pi bootloader
ii  raspberrypi-kernel                   1:1.20210831-3~buster                   armhf        Raspberry Pi bootloader

So, something was patched/updated. I never had the problem in the first place, so I can't really test, but I'll post back if I happen to notice anything significant.

1 Like

@TTalkington thanks! I'm doing a 71h print at the moment but as soon as it's done I'll update and give it a shot and report back

@TTalkington unfortunately same problem although it does seem reduced

@notfixingit OMG thank you! I was about give up on octoprint on my Ender 7

@jessietheunuicorn cool, glad it helped someone, was starting to think it was just me but this does make me question if the problem is somehow related to Creality 4.3.x boards since your 7 and my 6 have the issue but @TTalkington I believe has models with 4.2.x boards (please correct me) and does not have the problem.

One other question, do either of you have HDMI screens attached to your OctoPrint server? Trying to narrow down similarities/differences

Yes, both of my printers are 4.2.x boards. And I have an HDMI touch screen.

Just tried without HDMI attached and still had the issue, saw some commits related to HDMI so I figured it was worth a shot.

@TTalkington Maybe difference in firmware/bootloader? (although I have no idea why bootloader would make a difference but let's see)

vcgencmd version
Aug 31 2021 14:53:42
Copyright (c) 2012 Broadcom
version 67615e950e1e28b92dfae6303cf7a8b879a8908f (clean) (release) (start_x)

vcgencmd bootloader_version
Sep 3 2020 13:11:43
version c305221a6d7e532693cc7ff57fddfc8649def167 (release)
timestamp 1599135103
update-time 0
capabilities 0x00000000

rpi_update does show a update available but I don't want to try it yet unless ours don't match