[solved] No MMU print possible


#1

Does someone also ran into this problem?:
I wanted to print a dual color object with my i3 MK2MM via OctoPrint (1.3.9rc1) today.
The pre-purging worked fine but already the purge block was a mess.
Printing from SD card the same gcode was no problem.

So I did this:
Downgraded OctoPrint form 1.3.9rc1 to 1.3.8 -> no change.
Downgraded Slic3r PE from 1.40.1 successive to 1.38.2 -> also no success.

Now: Printing a delivered model (Marvin, Slic3r PE 1.34.1.3) works fine with OctoPrint
Single filament printing is no problem too.

The OctoPi version is 0.14.0. There are no error messages from OctoPrint.

First I assumed it was the "Display Layer Number" plugin because it slightly changes the gcode. But this one is not guilty.

Anyone any idea?

Eddy


#2

So darn - silly me!
This issue was home made:
I included GCODE scripts for handling pause events.

For Slic3r includes a user action request after priming, this was interpreted as pause and my script mixed up all the rest...

So, I can update everything again :blush:

But anyhow: Thanks for reading :+1:

Eddy


#3

I'm new to this can you please enlighten me as to what needs to be adjusted to avoid the pause after priming of filaments?


#4

Hello @Tacoma21!

AFAIK, this pause is hard coded into Slic3r.

M300 S800 P500
M1 S10

M1 is the pause command and S10 is the the time to wait in seconds.

My problem in this thread was, that I had additional pause code in OctoPrint that mixed the printer up in MMU mode.