[Solved] Octoprint wifi connection issue

What is the problem?
Since I change from a rpi 2 B+ to a rpi 3 B+ the connection stop during the printing session.
I do not have access on browser and via ssh, the print is not affected.
I had format my SD samsung Evo 32Go and put a fresh install for the new rpi 3 B+
The rpi 3 B+ is conncted to the lan on Wifi 5G

I never have had this problem with my rpi 2+, maybe I should pass to regular 2.4ghz wifi. ?!
What did you already try to solve it?
It is now the second time it occures and my print still in progress, so I had do nothing yet.

Logs (syslog, dmesg, ... no logs, no support)
I will edit this post later if I can to post the logs. For now my print still running and can not restart the raspberry until it's finish.
Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
rpi 3+ connected on Wifi 5Ghz
When the problem occured, the rpi disappear from the lan client list.

Does the server actually crash? If the print continues it doesn't crash so your title and this quote is a bit misleading and the whole situation sounds more like a DHCP lease running out and not being properly renewed or maybe an issue with power safe features of the WiFi NIC.

Hello foosel,

Thanks for your reply and sorry for the inappropriate title, I thought the process was independent.
I edited it, and you are right, it is a DHCP issue.


You might want to temporarily plug in an Ethernet cable then from a remote session:

sudo apt-get update
sudo apt-get upgrade


I've increased the lease time on my router that solved the problem.
Will do an update too when the current job will finish.

Thanks for your help :wink:

1 Like

Hi again,

My "fix" seems not to work. I lost the rpi 3+ after some times, seems to be a DHCP lease running out, but do not know why....and how to solve it.

Try a static ip :slight_smile:

1 Like

Thanks all for your help :wink: