[solved] Pi cam worked for a while, now doesn't

Camera: Raspberry Pi V2.1 on Pi3

The pi cam I installed for octoprint worked right away, then after a few days didn't.

When /root/bin/webcamd parses /boot/octopi.txt it comes up with this as the command string (taken from webcamd.log) which doesn't work. Plays a second of video, video freezes, then the service continually restarts:
/home/pi/mjpg-streamer/mjpg_streamer -o output_http.so -w ./www-octopi -n --listen -i input_uvc.so -rot 180 -r 1280x720 -fps 30 -d /dev/video0
Error in log: UVCIOC_CTRL_ADD - Error at Pan (relative): Inappropriate ioctl for device (25)

I surrounded the input and output strings with quotes it then works from the shell:
/home/pi/mjpg-streamer/mjpg_streamer -o "output_http.so -w ./www-octopi -n --listen" -i "input_uvc.so -rot 180 -r 1280x720 -fps 30 -d /dev/video0"

Not sure if it's related, but I installed the Camera Settings plugin around that time. Tried uninstalling it.

What could have caused the change and how do I fix it?

camera_usb_options="-rot 180 -r 1280x720 -fps 30"    -f doesn't work

Followed these instructions when installing

Octopi: Version 0.18.0, running on Raspberry Pi 3 Model B Rev 1.2

EDIT: I had Type="forked" instead of "forking" in webcamd.service
Now I'm a forking genius.

1 Like