[SOLVED] SerialException... only when heating the bed

My octoprint gives the error below whenever I try to preheat the bed. Only then. It'll sit connected indefinitely. No problems when moving the nozzle from the control screen or preheating the hot-end. But once I set a bed preheat, bam, she disconnects. I googled and searched solutions, but it all seems to be tied to powering the pi. I'm not getting an under power warming, it's a solid power source. I couldn't find a post that commented about preheating the bed being related to the issue.

EDIT: Just noticed - when I tell it to preheat the bed the screen on the printer pops up with the firmware version over top of the normal controls. V40.158.2 This also happens when I preheat on the machine itself. If I preheat from the machine it also gives the same error and disconnects me.

Error: (Error: SerialException: 'device reports readiness to read but returned no data (device disconnected or multiple access on port?)' @ comm.py:_readline:2793

I'm working with a MPSM, but I don't know what to do exactly. Log attached. Everything is up to date.

Additional Information:

Accessing via chrome
5 other printers with same build and same machine running fine
Octoprint Version: 1.3.12

octoprint.log (23.7 KB)

Update: Popped it open and found that one of the wires had come loose on the board. Re-attached. No longer disconnecting. But now... it wont actually heat up. Seems more of a printer problem than a OP problem. :slight_smile:

You might want to double-check that the printer itself is both plugged into its power brick and turned ON. (The Pi will backpower the printer board with 5V and make it seem like it's happy; it just won't heat up and the Pi usually runs in an under-voltage condition.)