[SOLVED]The host is in master mode


#1

What is the problem?
I see on the screen tons of lines saying : The host is in master mode
And i cant acces to the web inetrface
What did you already try to solve it?
I try to rewrite 2 times the image but not working
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Raspberry pi 2 , Octopi 0.15.1 , and nothing else


#2

I've never see that specific message before, but I have seen situations where something like that might pop up. Usually this will happen in a network with more than one server, and and it refers to what's known as a "master browser" because only one server can be "the boss" of the network

How many computers are in your network ? (remember, everything counts, including cell phones running strange software)


#3

About 19 with the router :slight_smile:


#4

Okay. Any of them running any kind of server software ?

File servers, media servers, kodi servers etc ?


#5

I have a western digital nas but it's always sleeping

it's on the raspberry screen not on octoprint.local


#6

This sounds like wi-fi terminology. The "master" is usually your Internet router which publishes an SSID and then receives DHCP requests from clients, issuing them IP addresses. It sounds like your OctoPrint is is "Hotspot" mode where it tries to broadcast an SSID, etc.

It sounds like this, to be honest, where it's describing how to turn the OctoPrint install into a hotspot.

In your workstation's Wi-fi selection area, see if there is an available zone called "Octopi" or similar.


#7

i'm not in wifi i'm in ethernet because i use a Raspberry pi 2


#8

Ah. Try this then: Gigabit master/slave mode.

Decides whether the adapter or link partner is designated as the master. The other device is designated as the slave.
Changing the setting can improve link quality with certain link partners.

Caution
caution icon Some multi-port devices can be forced to master mode. If forced to master mode, the device can either disconnect or downshift to a 100-Mbps link. The issue can also occur in a Forced Slave to Forced Slave mode. Changing this setting can cause a momentary loss of connectivity.

In this case, it sounds like the Raspi is deciding that it gets to decide what speed the Ethernet cabling/hubs are using. It feels like this is a problem in something else that's connected to the same hub. I think I'd look at the Ethernet adapter settings on the router or whatever else is physically connected to that.


#9

My nas is connected to the same hub did i try to disconect it and boot the raspi ?

On the hub i have only my main computer and the nas and , of course, the raspi


#10

The Raspi 2 has...

Network: 10/100Mbps Ethernet

You might want to run an ifconfig on your workstation, the Raspi and the NAS. You're interesting in the speed settings.

You may want to follow the advice here to change the speed or mode on the Raspi. I'm guessing that you want to turn off auto-negotiation to remove those messages.


#11

Could we maybe get a screenshot (or actual screen photo) of that ominous message?


#12


#13

Looks like a known issue with the Raspberry Pi kernel:

What USB devices do you have connected to your Pi? Try disconnecting one by one and check if the message stops flooding your screen, if so the device you unplugged is probably the guilty party here.


#14

It works without anything connected i will try to connect my camera


#15

ok every thing work now :slight_smile: thanks for all your help


#16

So was it the camera?


#17

Nope it was my keyboard

But thanks for help :slight_smile: