[SOLVED] Updated Pi and Octoprint - now have USB communication issues

#1

What is the problem?

I updated to 1.3.11 via the web interface and updated the pi with apt-get update apt-get dist-upgrade. All of a sudden, I started getting the message:

" Communication timeout while idle, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves."

and my printer will eventually stop printing, but the raspberry pi is still responding and I'm able to ssh into it.

What did you already try to solve it?

I am using a USB cable with ferrites on it. I unplugged the USB cable and replugged it again. I restarted the printer and the raspberry pi. I unplugged my camera from the pi so the only thing connected was the printer. My red light stays bright red and does not flicker. I did another apt-get update and apt-get dist-upgrade, but no more packages were available.

I changed all 3 max consecutive timeouts to 0 to disable them and I got horrible layer shifting. I've currently unplugged the pi and am printing the model from sd card to make sure I have no problems and no layer shifting doing that.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Running 1.1.9 bugfix Marlin on an Ender 3. Nothing has changed except updating the pi and octoprint.

#2

Share your octoprint.log and serial.log. If you haven't enabled the serial log you'll need to enable it and then run a print.

#3

Ok....it was much longer than could put here. It ran for a couple of hours before bombing, but most of it was send line then receive ok. I removed most of that so I could post it here. I only included the areas where the send and receive differed from the aforementioned.

serial.log (100.2 KB)

#4

octoprint.log (769.6 KB)

#5

What I've seen:

  • there is a report of undervoltage. Not much, but if it is seeing power problems, the Pi runs at half speed.
  • the serial failures are crazy. There's something seriously wrong. How long is your USB cable? (I know you said ferrites)
  • use a second SD card and install a basic version of octoprint, see how it works.
  • there's a tracking exception in the logs. It points to oddities in the upgrade.
  • running apt upgrades aren't necessarily a good thing.
  • how large is the gcode you're trying to print? what's the estimated print time?

So, all these things point to at least trying out a second Octopi install.

#6

I replaced the power cable several days ago with a better one. Right now, vcgencmd get_throttled is returning 0x0....that it's never been throttled.

My USB cable is less than two feet long.

The gcode is 4 lids for enclosures. The estimated print time is just over 7 hours.

Is there a way to reinstall octoprint from the commandline...so we at least make sure the upgrade is good?

#7

Never been throttled since last reboot; there was an entry in the logs from ~48hrs ago.

How large is the gcode file? I don't think that's it, but still curious.

You don't want to reinstall from the cmdline, flash a new SD card.

#8

The gcode file is 10.6 MB

Is it ok to backup and restore my settings if I flash a new SD card rather than reconfigure it?

I did the pip https get latest lines I found online and I'm at least trying that first. It probably won't make a difference, but there's a chance

#9

Yeah, you can copy the config.yaml and such once you have it up.

#10

Thank you very much for your help. I didn't have to flash another SD card. The reinstall worked. It cleared all the communication errors up.

To summarize for those who may be reading:

I had octoprint 1.3.10 working fine. I updated to 1.3.11 via the octoprint web interface. All of a sudden, I started getting USB communication errors:

"Communication timeout while printing, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves."

After a lot of those, eventually octoprint would throw several in a row, say the printer was no longer responding and disconnect it. My print would freeze.

To solve it, I typed the following:

~/oprint/bin/pip install https://get.octoprint.org/latest
sudo service octoprint restart