[SOLVED] Webcam scripts not called "automatically"


#1

Hello all,

I've done a fresh install of octoprint 1.3.8 on a fresh install of raspbian 4.14 2018-04-18.
I've followed the original instructions here

Everything is working except the webcam streaming. I'm using a logitech C270.

The things is that the camera doesn't turn on (green LED) when going on the control tab. And I get the faillure message instead of live stream :

Webcam stream not loaded
It might not be configured correctly or require authentication. You can change the URL of the stream under "Settings" > "Webcam & Timelapse" > "Stream URL". If you don't have a webcam just set the URL to an empty value.
Currently configured stream URL: http://192.168.0.14:8080/?action=stream

Trying to stream the URL directly on a new tab gives the same result : "not responding".

But manually calling the scripts "webcam start" and "webcam stop" from an external terminal effectively starts and stops the stream, and the control tab shows the webcam stream correclty (with keyboard controls). Going to the URL also shows the live stream as expected.
I've verified the executability of the scritps (chmod +x), all directories etc... But I get stuck.

I changed the username on the octoprint installation (I put "pi-octo" instead of the original "pi"). Does this change the right of calling the scripts for webcam stream ?

Thank you very much.

SouD.


#2

Ok guys...
I wrote "action" instead of "actions" in the config.yaml file...

Now i understand that the webcam don't start automatically but i should use the system icon and command buttons on the top bar of the screen !

So stupid mistake.
My fault.

Thank you anyway.