[solved] [yawcam] Laptop webcam won't stream (will take snapshots)

i have octoprint on an ASUS laptop and want to use the built in webcam. i installed yawcam as instructed in "setting up on windows" guide, leaving everything default and turned on streaming and http.
i forwarded the ports in router. for <ip_of_your_pc>, it is the internal/local IP (eg 192.168...)
i turned off webcam control for bitdefender.
in octoprint, when i put in "http://<ip_of_your_pc>:8081/video.mjpg" for streaming and "http://<ip_of_your_pc>:8888/out.jpg" for snapshot/timelapse, the snapshot test will take a picture from camera, but the stream is not recognized. i have tried removing the "video.mjpg" from the address. this still does not work, but in the "control" window black screen where video should be, if i click on the "http://<ip_of_your_pc>:8081/" link, a browser window opens with the camera showing. (if i click on "http://<ip_of_your_pc>:8081/video.mjpg", the browser gives a 404 error and no camera shows).
when i test yawcam connection from the yawcam app, both ports show "OK".
there is a post (OctoPrint in Docker, snapshot works, stream doesn't) very similar to my problem except mine is on a windows pc.
i just installed for first time and have latest versions of everything (1.8.6)
octoprint-systeminfo-20221118154830.zip (31.5 KB)

could someone please suggest how i can get the streaming to work (eg what i am doing wrong :slight_smile: )

NOTE PROBLEM SOLVED: turns out that yawcam has a setting in the "output --> stream" section where you switch between "java" and "mjpg". it defaults to "java" but that setting is not mentioned in the guide. changing it to "mjpg" fixes the problem.

First of all - never do that. That's not secure at all.
Also if you just want to access the stream on your local network you don't have to forward anything.

That post isn't really similar. It's like your car doesn't have tires and the car in the post doesn't have an engine.
Both cars don't drive, but it isn't a similar issue :wink:

Glad you figured it out. Thanks for letting us know :slight_smile: