[Solved] Youtube Plugin and YouTube Live Error ('Connection aborted.', error(2, 'No such file or directory'))


#1

Hello,
I am new here and already have a question :sunglasses:

I am trying to create a Youtube Stream with my (actual) octoprint, following the instructions from @jneilliii here. The Cam works well, i can see the stream via


but i get the error message " YouTube Live Error ('Connection aborted.', error(2, 'No such file or directory'))" an didn't really know, how to solve the problem.

I'd insert the text from the youtube information about my User Id to the field "Nutzer -Id in the youtube plugin and the Name / Key to the "YouTube Stream ID" field in the Youtube Live plugin.

So please excuse my confusion, but i can not find a working solution with the forum search.

Thank you in advance for your help,
Rob


#2

You should search the issues of the repository on github. The problem you're experiencing is because the url tou have in your webcam setting needs to be a full address not a relative one. So make it http://192.168.0.2/webcam/?action=stream restart octoprint and it should work. Make sure to use your pi's ip address...


#3

Thanks for your answer, but unfortunately that hint did not solve the Problem:

http://192.168.178.112/webcam/?action=stream

result is:

YouTube Live Error

('Connection aborted.', error(2, 'No such file or directory'))

Q: is there a debug Option?

--
Rob


#4

Debug Option? Octoprint Settings / Logging / Logginglevel
Then via ssh as user octopi: either 'less ~/.octoprint/logs/octoprint.log|grep youtube*'

or, if you have no old logs, just start "go live", then watch
'via tail -f ~/.octoprint/logs/octoprint.log|grep youtube*'

T.


#5

Hello everybody,
please excuse my late reply, I had a long print job on the run, I did not want to interrupt this. But I used the time and looked closely at what the problem was. I myself was the problem. :sunglasses: I thought it was enough to install the plugin. That it is necessary to install a Docker container escaped me somehow. Unfortunately, one does not notice that at first glance, as a naive user ...
Anyway, now it works. In between, however, I have interruptions of the stream, probably because of the full resolution, which I use with the standard cam of RaspBerry? Is there a better recommendation that runs on the 3B + model?

Thank you again,
Rob