Space issues on micro SD card


I'm a bit new to Octoprint... it's been working pretty well so far, but lately, the issues I've been seeing seem to be due to "space" issues on the SD card. I have an 8gb card in there right now, which I figured would be plenty as I didn't plan on keeping old print files on there. The only one I have on there currently is only 5mb.

I recently tried to upgrade Octoprint and that's when I first saw the space error. Then I removed some print files and tried again, got the error again. I tried to add the Spaghetti Detective plugin and got the space issue. I gave up trying to update or add a plugin and went back to uploading the occasional print and using the cam to monitor, which worked fine until this morning.

After the first successful upload and print, I deleted it and tried to upload a 35mb print file and got another space error, so I gave up and am printing via local SD card at the moment.

Is there a possibility that the failed installs left trash files on my card? I'm a bit new to linux, so I apologize in advance for my noobness.

I'm using a Raspberry Pi 4 model b with an 8gb micro sd card (can't remember the brand, but it's a brand name) and here are the versions of Octoprint and plugins I'm using:

OctoPrint : 1.3.12

Automatic Shutdown : 0.1.4

Autoscroll : 0.0.2

Change Filament Plugin : 0.3.0

FileManager Plugin : 0.1.3

Fullscreen Plugin : 0.0.4

Multi Colors : 1.0.16

Themeify : 1.2.0

WebcamStreamer Plugin : 0.1.1


octoprint.log (336 KB)

What is the problem?

What did you already try to solve it?

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

First things first, learn a little Linux.

df      # This might take a while
Filesystem     1K-blocks    Used Available Use% Mounted on
/dev/root        3998528 2893888    964988  75% /           <----- This one
devtmpfs         1711484       0   1711484   0% /dev
tmpfs            1843580       0   1843580   0% /dev/shm
tmpfs            1843580    8776   1834804   1% /run
tmpfs               5120       4      5116   1% /run/lock
tmpfs            1843580       0   1843580   0% /sys/fs/cgroup
/dev/mmcblk0p1    258095   54165    203930  21% /boot
/dev/sda1        3885696   15104   3870592   1% /media/usb0
/dev/sdc1       15343640   48424  15295216   1% /media/usb1
tmpfs             368716       0    368716   0% /run/user/1000
/dev/sdb1        3863668     456   3863212   1% /media/usb3

In my case, it looks like that 2nd 4GB partition is using 75% of that space.

It looks like I've not auto-expanded my file system since the last time I was making a backup. Note that I have a 32GB Class 10 microSD in my Pi 4B so obviously I'm not using all of it.

So where can I clean things up?

ls -l ~/.octoprint/logs
ls -lR ~/.octoprint/timelapse
ls -l /var/log     # Needs sudo to individually rm them

What's funny is that people will get BIG microSD cards and then be surprised when they fill up faster than smaller ones. Raspbian knows when you have more available space and the journalctl will let the logs grow bigger as a result of this.

Honestly though, an 8GB microSD is usually sufficient for an OctoPrint install. Archive off any timelapses to start and see what df says.

Could it be that you just pull the plug when turning off OctoPrint instead of shutting down?
Chances are that the filesystem got damaged.

I think that might've been it.. thanks!