Spongy prints after changing the Heater

octoprint-systeminfo-20230429102203.zip (62.3 KB)

What is the problem?

After I changed the extruder heater, my prints are spongy, like its not extruding properly. Also changed the feeder tube and connectors, changed the tip several times. Extrusion comes out round and easy. 18 failed prints, tried different colors. I don't hear any clicking while printing.

What did you already try to solve it?

I changed the feeder tube and connectors. I have reprinted an old slice that came out good before I changed the heater. Now that print is spongy too. Could it be the extruder motor? Is there a method to test it?

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

I think I attached the file correctly.

Additional information about your setup

Creality Ender 3, MARLIN VER 1.0.1 2020-04-25 SINGLE EXTRUDER, BAUD RATE 115200
Using a Raspberry PI with OctoPrint ver 1.8.7


Not quite sure what spongy means - could you show us a picture of those failed prints?

Have you done a PID tune?

Printing Lithophanes, I've done many in the past, never had this happen. Top circle is an image of the base of a Lithophane, clearly not mending. Middle circle is a "sponge", it is soft, this should be a solid, 100% fill.

I don't see PID tune on this website. I'm searching the internet, found some videos. Let me see what I can do.

Here are some more pictures, the orange cup is softer than Styrofoam, and just crumples with no effort.

It seems you have a quite spongy USB connection:

2023-04-29 09:01:26,322 - octoprint.util.comm - INFO - Got a resend request from the printer: requested line = 55146, current line = 55149
| Last lines in terminal:
| Recv: echo:Unknown command: "í``8‚úmËv"
| Recv: ok
| Send: N55141 G1 X124.962 Y90.816 E3043.26679*98
| Recv: ok
| Send: N55142 G1 X126.705 Y92.204 E3043.34089*109
| Recv: echo:Unknown command: "¥”T«ÚÔâ}ê)1í§ú÷ÿ£{à vˆÛ6EÈýïquïjT„#ͯ£)PL"
| Recv: ok

And at a certain point the extruder does not heat any more:

2023-04-29 09:01:39,108 - octoprint.util.comm - INFO - Got a resend request from the printer: requested line = 55331, current line = 55334
| Last lines in terminal:
| Recv: echo: cold extrusion prevented
| Recv: ok
| Send: N55328 G1 X129.607 Y122.62 E3051.00478*105
| Recv: echo: cold extrusion prevented
| Recv: ok
| Send: N55329 G1 X130.449 Y121.11 E3051.06228*106
| Recv: echo: cold extrusion prevented
| Recv: ok

Check your USB cable and the check the wires and connectors of the new heater cartridge.

1 Like

Yeah there is definitely an underextrusion problem, besides of the usb connection problem that @Ewald_Ikemann pointed out.

Doing a PID tune could be necessary, but that depends on how your temperature graph looks like.
If you got a flat line everything is fine :smiley: But if it looks really wavy and it's heating/cooling all the time and can't maintain a stable temperature you really should do it.

But if you changed the heating cartridge with a replacement part and put the thermistor back where it belongs that usually isn't needed.

I guess there is a problem with the tube.
On the ender 3 it has to make contact with the nozzle or plastic will ozze out / melt at the wrong location and block the way.

Here is the way I assemble a Ender 3 hotend:

First I preheat it to something like 160°C, then I screw the nozzle 90% in, then I insert the bowden tube (make sure that the end got a clean cut so it can make a good connection), then I screw the nozzle all the way in.

In this way, the nozzle compresses the tube a little, which contributes to better contact.

I did have a problem with leakage. When I first put it back together, I didn't seal the bowden tube and had plastic "bugers", dark, burnt blobs of plastic appearing on my print. There are some shown in my first picture, upper left corner. I cleaned everything and put it back together correctly, but may have caused something to go wrong. So maybe I need to clean out the hole where the thermister is??

The USB cable seems okay, I saved the print onto a Micro SD and still have the same problem.

I didn't realize it, but I was attempting to manually extrude at room temp. After the third failed attempt to extrude I realized that there is a safety and I turned on the heater. I think that is what you see. I just performed a PID tune up using Pronterface and I still have the problem. Is it possible to provide a system bundle using Pronterface ?

1 Like

octoprint-systeminfo-20230430124054.zip (73.9 KB)
I have done another print and updated my system info.

I ran a new test. Measured 120mm and marked the filament. at tempurature, ran the extruder 100mm. I measured again, 80mm. Looking at the extruder, it appears to be slipping. But I cannot determine why.

Run the test more than once. If the results vary from test to test then there is probably a problem that needs to be addressed. If the results are consistent, then you just need to change your e-step value.

Cleaned my extruder gear, test looks good. attempting another print....
I am also ordering new gears for the extruder.

Well, it failed again. I'm going to wait for the replacement gears to arrive.

Try to heat it to 220 (pla), then hold the extruder bypass lever and push the filament in by hand.
You should be able to push a nice amount of plastic through the hotend. If that doesn't work or there is next to nothing coming out of the nozzle then it's still an issue with the hotend.

If you only changed the heater, before things went wrong, that is your problem. Extruder does not sound like your problem.
If a SD card print works, but not Octoprint, the USB may be a problem.
The new heater you installed, check its resistance. You may have installed a 12V heater, Ender is a 24V system. That is most likely your problem as you get to temperature, but seems cannot keep up heating the filament. Good practice to use a bit or heat conductive paste on the heater, to get good transfer to your heatblock. Also the temp-probe does well with some paste. Make sure it has good contact with the heatblock when cold and hot, things move sometimes when heated.
If you eliminated all of these possibilities, Then look further to other systems.

I have installed the aluminum extruder with gears on both sides instead of just one side like the original plastic one. I am now up and running. Thank you for all your help.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.