Stepper motor not working during prints - Ender 3v2

What is the problem?

I'm having a stepper motor problem on my ender 3v2.

My Ender 3v2 it suddenly stopped extruding yesterday mid-print.
Now I cannot get the stepper motor to work during prints.

The stepper motor works when I'm calibrating it, when I go to the Control Tab and command it to move some millimeters it pushes the correct amount of filament.
But as soon as I add a print, the nozzle will be moving around but without any filament coming out because the stepper motor is quiet and won't push any filament to the hotend...

I tried changing the e-steps on my control tab in the configuration of the printer.
I changed the original extruder with a double-gear extruder

What do I do?
Thanks in advance for any help.

Did you upgrade your firmware on the motherboard?

I did not, the printer was working flawless since I got it a few months back.
The extruder stopped mid-print yesterday.

This is my next step, then. I'll upgrade it now with Jyers.

I updated the Firmware with JyersUI 1.3.4.
Nothing changed, the nozzle keeps going around the bed but the extruder doesn't move, so there's no filament coming out of the hotend.

The Extruder (the stepper motor) does work, as when I go to the Menu: Prepare/Move/Extruder and input any value there, the motor does push the correct amount of filament.

This leads me to think it's some configuration that changed.
It was working fine for months on end and suddenly stopped pushing filament halfway through a print yesterday.

Please help!
Thanks in advance.

Well if the extruder stopped working without anything it might be something else like bad temp reading (cold extrustion etc)

The print starts fine, the temperature is appropriate and it all works.
It is only the stepper motor that remains still when I start a print instead of turning.

So temperature reading is likely not the issue, as it does turn (pushes filament) when I go to the Menu command.

Tried printing from SD card etc.

What happens if you execute filament extrude from terminal?

Yes, that's my point. It works if I extrude from the touch screen.
So the stepper motor is working.

What I'm thinking is that some configuration went bogus inside the machine and is telling the printer not to use the stepper motor when I start a print.

Configuration inside the machine is 99% firmware and the some config - have you tried printing from SD Card?

If you have OctoLapse installed, disable 'Test mode'. This will go through the actions of the print, without extruding any filament.

1 Like

This tripped me up for a good while when first learning OctoPrint. Disable 'Test Mode' for sure.

1 Like