Steps to Install TouchUI for kuman 3.5"

Hey Guys -

I've spent hours trying to get TouchUI working correctly. When doing so, the display didn't work, touch was messed up, or there was always some issue. None of the steps I had seen from others worked nor did the troubleshooting steps on TouchUI's page. When rebuilding my OctoPrint server (setup from scratch) recently, I tried again and finally got it to work.

Below are my system specs at the moment followed by how to get it to work if having issues:



  1. Install Octoprint and set up as desired - You may physically install the LCD now but do not yet install the TouchUI plugin
  2. Connect to Octoprint RasPi via SSH
  3. Execute "sudo apt-get update && apt-get upgrade" to upgrade all packages
  4. Execute "sudo apt-get dist-upgrade"
  5. Execute "sudo reboot now" to reboot
  6. Reconnect via SSH once back up
  7. Execute "sudo apt-get install xserver-xorg-video-fbturbo" - depending on your OS image, this will probably fail which is normal
  8. Execute "sudo reboot now" to reboot
  9. Reconnect via SSH once back up
  10. Execute the below commands to install the driver. Note that the final command auto restarts your RasPi without prompting and you may notice some errors prior to this...

sudo rm -rf LCD-show
git clone
chmod -R 755 LCD-show
cd LCD-show/
sudo ./LCD35-show

  1. Once back up, log back in via SSH again then execute "sudo apt --fix-broken install" to resolve the errors encountered prior to auto reboot
  2. Execute the below two commands again which should now succeed and auto reboot again

cd LCD-show/
sudo ./LCD35-show

  1. Reconnect via SSH once back up
  2. Execute below commands to configure & rotate display:

cd LCD-show/
sudo dpkg -i -B xinput-calibrator_0.7.5-1_armhf.deb
sudo ./ 180

  1. Execute "sudo reboot now" to reboot
  2. Reconnect via SSH once back up
  3. Very orientation is correct (although should only see text). If not, rerun "sudo ./" again with a different rotation value instead of 180
  4. Launch browser, browse to OctoPrint's WebUIm then install the TouchUI Plugin
  5. Once installed, ignore prompt to restart in the WebUI and instead execute "sudo reboot now" via SSH
  6. Reconnect via SSH once back up
  7. Execute the below two commands to run TouchUI's helper script. Note that the 2nd command may take a few minutes to complete but once done you should get "Success" for all components

git clone ~/TouchUI-autostart/
sudo ~/TouchUI-autostart/helpers/install

That's it - TouchUI should now be displayed and touch calibration work.

Note: If prompted for credentials on screen after final reboot, edit ~/.octoprint/config.yaml and verify that the below lines are present within the AccessControl: section at the top

autologinLocal: true
autologinAs: yourusername
salt: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Hope that helps someone. Thanks!


From the sound of things, this technique installs the Desktop (x windows) GUI. It's just good to know that up-front.

Have been struggling with trying to get my Kuman 3.5" , (it's the HDMI version MPI3508) ,working, i think i'm close but not quite there yet.. i see the touchui splash screen as it says connecting to touchui and then i just get a black screen with a mouse pointer. and occasionally i see a white screen with a little page with sad face that can't be good hah. still not registering any of my touch inputs at all.. Must have taken a wrong turn somewhere, do i need to do something different since i have the HDMI version? Thanks for the guide!


Hey Guys -

Just had to set my OctoPrint back up and when doing so realized that I had a couple of the steps wrong. I just edited the steps posted above which I have verified are now correct

Good luck - Thanks!

It would be great if you could edit your first post so nobody gets get confused :slight_smile:

You're right - should have done that to begin with. Just updated. Thanks

1 Like

Thank you so much i struggled now with this problem for at least 20 hours. I tried every explanation i could find but this was the first one which worked fine.

Thanks for the guide. Does anyone know how to prevent it from auto booting into TouchUI or how to access the Pi's terminal? I'm needing to configure a humidity sensor and need access to terminal.


Hi I've followed your steps and i get a failed message
Running apt-get update (this will take a while)
Do NOT switch off the Pi or close this console until done!

  • success

Installing dependencies (xinit xinput xserver-xorg xserver-xorg-video-fbdev x11-xserver-utils matchbox unclutter chromium-browser):

  • failed
    any advice?


hi bzowk after two days of video on youtube the frustration was very high, but I managed it thanks to your guide. I just have a problem, she asks me for credentials and I didn't understand the last step to not let her come. thanks

1 Like

jai le meme probleme sa marque please log in

I got the same error message than Haggis239.
Searched Google and got the answer from Billy Blaze's git

Thank you for the guide!

thx for help

Same problem. Did you ever find a fix? Thanks!