Strange Issues with New Install of OctoPi/OctoPrint

#1

What is the problem?

I am unable to upload GCode and STL files or to import an profile into Cura.

In the case of the .gcode file uploads, OctoPrint complains about an "Invalid API Key"

What did you already try to solve it?

  • Rebooted
  • Checked for upgrades (OS/App/Plugin)
  • Searched for relevant Github Issues
  • Searched for similar topics in discourse
  • Renamed files as simply as possible
  • Tried different STL files
  • Tried previous profiles (all from Cura 15.04.x, and older ones previously used with OctoPrint)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Fresh install
I used Balena Etcher to burn OctoPi image onto previously used class 10 SD card

OctoPrint Version 1.3.10
OctoPi Version 0.16.0, running on Raspberry Pi 3 Model B Plus Rev 1.3

#2

If you burned a new image, presumably you then got a new API key generated. Perhaps this is just a browser-caching thing? (Try a hard-reload from your browser window, whatever that is on your particular one.)

1 Like