Strange network issue

What is the problem?
Everything seems to work except the octoprint server connecting out on the internet.
I installed 2019-09-26-octopi-buster-lite-0.17.0.img on a Raspberry Pi 3. I run these from hardisks not the sd cards. This isn't difficult and I had 2 set ups running for 4 years (older versions of octopi).
I updated these using the normal apt commands.

What did you already try to solve it?
looked in the log files: this is the section with errors

I tried to paste the portion of octoprint.log here, it pasted fine but because it contains what your system considers links it won't let me create the topic. I'll try to find someway to upload the file.

editing post might let me do this. Nope, I'll just cut some out

2020-10-20 02:10:35,194 - octoprint.plugins.announcements - ERROR - Could not fetch channel _important from HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /feeds/important.xml (Caused by NewConnectionError('<urllib3.connection.VerifiedHTTPSConnection object at 0x72060ff0>: Failed to establish a new connection: [Errno -3] Temporary failure in name resolution',))

I can do most anything from the command line, I can ping all hostnames involved above (,, octoprint.plugins.announcements, ...). The online connectivity test passes with any dns nameserver I've used.

Raspberry Pi is hardwired, no wifi involved.

Logs (syslog, dmesg, ... no logs, no support)
syslog and dmesg show nothing abnormal, all failures had to do with video and webcam, not connected to a printer just yet.

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

I use a pfsense router, no problems with any other computer connected (there are 6 including the 1 older octoprint setup that still works.

You can upload it here.


That indeed looks like a DNS problem, but you've already said that DNS works in principle. I guess we'll need logs to get a broader picture.

1 Like

For what it's worth. I got it working, but not by fixing anything. Here is what I did.
Straight install of 0.17. Things work, I can see updates, plugins, announcements.

I run
sudo apt update
sudo apt upgrade
things still work.
if I run
sudo apt full-upgrade
it breaks.

At the recommendation is:

Note that full-upgrade is used in preference to a simple upgrade , as it also picks up any dependency changes that may have been made.

Generally speaking, doing this regularly will keep your installation up to date for the particular major Raspberry Pi OS release you are using (e.g. Stretch). It will not update from one major release to another, for example, Stretch to Buster.

So I'm working now. I did still attach the log.
octoprint.log (90.2 KB)


Ah. Yeah, I gotta admit that I no longer really trust Raspbian dist upgrades. Too much breakage reported over the years. If you want to update to a new version, backup, reflash, restore. Everything else is just asking for trouble.

Update & upgrade will get you security updates just fine.

1 Like


but full-upgrade is not a dist-upgrade, but a full-upgrade of the current distribution (I think that means that they add "the rest" of buster to "buster-lite"). Supposedly the difference between upgrade and full-upgrade is the dragging along of dependency upgrades for any new packages that get installed. That might mean that some new package is replacing a dependency in the current buster-lite install, I'm not sure.

Anyway, it is still working fine as long as I don't upgrade more than was in "buster-lite".


As far as I can see after a bit of research, full-upgrade is in fact an alias for dist-upgrade.

Learned something new today. Also my point still stands :wink:

1 Like


I'm not intending to start an argument, but someone should tell


it states:

"Note that full-upgrade is used in preference to a simple upgrade, as it also picks up any dependency changes that may have been made.

Generally speaking, doing this regularly will keep your installation up to date for the particular major Raspberry Pi OS release you are using (e.g. Stretch). It will not update from one major release to another, for example, Stretch to Buster."

Your reply by email didn't arrive in full, so I'm not sure what exactly you were saying. However, my point was, if it's an alias in code, it's the same implementation, and my experience with dist-upgrade on Raspbian based images has always been very hit and miss, so that also extends to its alias full-upgrade. Whatever this whole smart package management is doing, it's not playing well with the additional packages included in Raspbian in my experience (more stock Debian however has always been fine). That's my whole point :woman_shrugging:


Just a jump here in support for @foosel :wink:

Upgrade : you will upgrade any installed package which has an upgrade. It will install new packages if those are needed for upgrading the aforementionned ones.
Dist-Upgrade: exactly the same but with a very noticeable difference : full-upgrade will remove packages if it's necessary

A few years ago, many tools came to "replace" the good-old apt-get. I think of aptitude, and nowadays apt. To be clear, these two one never really wanted to be a replacement (nor they are), they aimed at being a more user-friendly tool. And what is not user-friendly ? "DIST-upgrade" is not helpful for a user. Hence, they named it full-upgrade which is a bit better. Today, as you see, it's the same. Older people (like me) tend to still use dist-upgrade (yeah, muscle memory), but there's no difference in it.

Why does it fail with Raspbian and/or Octopi ?
Both are big modifications from the Debian original system. To get things done, developpers (i.e. creators) of Raspbian & Octopi have to force some tools to get installed; they force some config, sometimes they use fix versions known to work well with the very specific hardware of the Pi.
But when you use full-upgrade, you ask apt to completly ignore this manual, specific work, and try to do things automatically, just based on packages version. While it works really well on x86 "general-usage" computers (or servers), it's not going to work as easily with Raspbian, because Debian (and GNU/Linux) was never made for Raspberry Pi. Until a few years, You'll have to take care on how much you manipulate your OS on a Pi (and on an ARM-based computer, in general).

I hope this bit of history helped. I'm not saying anyone is wrong here. Just trying to let you know why, in my humble opinion, no one actually is :wink:

Have fun, take care !

1 Like

What I said was that I wasn't trying to start an argument, but states in their update documentation that full-upgrade was preferred over just upgrade for upgrades of a given distribution. That full-upgrade was not dist-upgrade and that it would not go from one distribution to another. full-upgrade is supposed to fully upgrade a given distribution (say buster) but that it will not upgrade from one distribution to another (say stretch to buster). These are not my words they are paraphrased from

I was only attempting to point out that there might be some differences between buster-lite and buster that a full-upgrade is stomping on.

As I mentioned. says the opposite. All I was trying to do was point out that the available documentation says full-upgrade is preferable to just upgrade for upgrading a given distribution and that it would not upgrade from one distribution to another. I don't know the truth, just stating what the documentation says. I was thinking that there was a difference between buster-lite and buster that was being broken by moving from buster-lite to buster with full-upgrade. I know that my raspberrypi still thought it was at buster after the full upgrade.

That link above directly compares what they call the difference between full-upgrade and dist-upgrade in terms of full-upgrade upgrades stretch but will not upgrade from stretch to buster. dist-upgrade will upgrade from stretch to buster.

Again, I'm not here to argue, I was just passing along what I thought was happening when upgrading a new buster-lite based octopi install based on the documentation available to me.

I won't try again.

This is the same thing I am getting. I've tried a new sd card, new install.
Pi is hardwired the only difference is I am using octoPi 0.17.0.
I can only see this on my network when hardwired in. When trying wifi it doesn't show up. I've tried two different pi's same thing.
octoprint.log (36.6 KB)