Strange Octoprint behavior

In "Control" if you click on X/Y "Home" and then "Extrude" or z Up/Down carriage will start slowly drifting in all 3 directions fore some time and then execute requred command. If you repeat same command that effect will not show but if you repeat X/Y "Home" it will do it again.

Browser Google Chrome

Printer Anet A8 original Firmware

Raspberry Pi B3+ 32Gb

octoprint.log (17.1 KB)

That could be the problem.

Please upload the serial.log

serial.log (444 Bytes)

Had the same behavior with the stock Anet firmware sometimes, could not be reproduced reliably, so I didn't bother to investigate further.
I recommend you flash Marlin, it's easy to configure and already has a pretty good preset for the A8 built in. I had no such problems since I run Marlin on mine.

Don't like Marlin. Tried it several times and returned back to original Anet A8 stock firmware. Works pretty good for me while Marlin nothing but problems.

@TazerReloaded fullack - my A8 did strange things as well.
@red_star_rc your choice :slight_smile: and if you open your uploaded serial.log you'll see a special message just for you :wink:

serial.log (7.4 KB)

Here is serial log enabled

Anet A8 firmware IS Marlin firmware.

Mine was also shipped with marlin.
It seems like this one is running repetier though.


@red_star_rc I don't see anything wrong in your log. Does it also happen if you home via the terminal with G28 X0 Y0 Z0 ?

1 Like

G28 X0 Y0 Z0 executed as it supposed to. However after that if you go to Octoprint "Control" and click on for example - move z 10mm UP it does drift all axes and extruder for a while. Then it works as normal.

Same happens if after G28 X0 Y0 Z0 you click on "Extrude"

However if after G28 X0 Y0 Z0 you click on "Move Y 10mm forward" it moves X 10mm back

If after G28 X0 Y0 Z0 you click on "Move X 10mm forward" it moves X and Y 10mm back.

You might try to run these one at a time in the Terminal tab. Report back if anything does something wrong. Moving X should move X and not Y, for example. Moving Z using a positive value should make the extruder higher in relation to the bed. (In some cases OctoPrint's printer profile needs you to check the invert checkbox otherwise.)

G28      # Nothing else. This should home X/Y/Z & E
G90      # Set motors to absolute mode
M83      # Set extruder to relative mode
G0 E10.0 # Extrude 10mm in relative mode
G1 X60.0 # Move the X axis to absolute position X=60.0
G1 Y60.0 # Move the Y axis to absolute position Y=60.0
G1 Z60.0 # Move the Z axis to absolute position Z=60.0
M82      # Set extruder to absolute mode
G92 E0   # Zero the extruder
G1 E10.0 # Extrude 10mm in absolute mode
G4 P5    # Wait five seconds
G1 E20.0 # Extrude another 10mm in absolute mode 

Besides this small and really weird oddity printer works absolutely perfect.

So running those commands individually gave you the expected behavior? If so, then it's possible that something is giving odd absolute-versus-relative commands which compete with each other.


my Octoprint wont connect to my printer all of a sudden, but in pi, i can see it......

[   80.543196] usb 1-1.3: new full-speed USB device number 3 using xhci_hcd
[   82.428832] usb 1-1.3: New USB device found, idVendor=11f1, idProduct=251d, bcdDevice= 1.00
[   82.428838] usb 1-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=3
[   82.428843] usb 1-1.3: SerialNumber: 3FM3WPUS5TH8A60472
[   82.470535] cdc_acm 1-1.3:1.0: ttyACM0: USB ACM device
[   82.472293] usbcore: registered new interface driver cdc_acm
[   82.472297] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters

Connecting to: /dev/ttyACM0
Changing monitoring state from "Offline" to "Opening serial port"
Connected to: Serial<id=0xaae10630, open=True>(port='/dev/ttyACM0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Changing monitoring state from "Opening serial port" to "Connecting"
Send: N0 M110 N0*125
No answer from the printer within the connection timeout, trying another hello
Send: N0 M110 N0*125
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

tried resetting everything, multiple times at this point, i can't figure out what is going wrong.

Does that have anything to do with the drifting A8 or are you just hijacking the thread?

I am sorry i am new to the forums and i did not know how to start a new help topic at the time, i have learned that now, and i have fixed this issue as well. you may delete it if you need to. sorry about that.

1 Like