Stream does NOT work, snapshot works

Camera model

IP Webcam on an Android phone

What is the problem?

Snapshots work at this URL:
Streams do NOT work at this URL:

Using the latest version of OctoPrint installed in Docker on a thin client. The installation has been working perfectly for the past year or so. Today I wanted to add a camera, but I can't get the stream right.
I'm including a screenshot of the failure, just in case, as I don't know what it is supposed to display if it fails/succeeds:

What did you already try to solve it?

Tried the stream in VLC (works) and in browsers (it works), so the stream is probably OK.
Also tried to lower the resolution/framerate of the stream, but nothing helped.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (83.9 KB)

If it works in the browser directly it's most likely some kind of conflict when trying to embed the stream in the UI. Browsers don't allow you to mix https/http, IP addresses and hostnames, these kinds of things.

Open the browser console and see if you can find the error there.

1 Like

Bingo! That was it. I am accessing my OP installation using https via Traefik.

When I access OP via its IP address directly (i.e. http://x.x.x.x:5000), it works perfectly. Thank you!

Unfortunately, it still does not work when mixing FQDN (for OP) and IP address (for the stream), even though I explicitly allow unsecure content in Brave's per site security settings. It is probably a Traefik issue, will look into it later.

At least I know what direction I need to go!

Thanks again!!!