Stream not showing, but shows in Cura slicer

Camera Model: Elipenico Wecam HD with Microphone
Amazon link:
The webcam stream in octoprint won't show and keeps loading, but it shows in Cura's octoprint connection extension
Stream url: "/webcam/?action=stream"

I tried changing the stream url, but that didn't work
cura.log (3.8 MB)
octoprint.log (31.3 KB)

The provided template will give us valuable information about your setup, and how to help you.

You can edit your message with the template which I pasted below. Please fill in as much information as you can, and especially the logs that are asked. Otherwise it will be very hard to help you out.

<!-- ~~~~~ Filling this out properly makes it WAY more likely to get help quickly ~~~~~ -->

**Camera model**

**What is the problem?**

**What did you already try to solve it?**

**Logs** (`/var/log/webcamd.log`, syslog, dmesg, ... **no logs, no support**)

**Additional information about your setup** (OctoPrint version, OctoPi version, ...)

and please post the webcam url you have currently configured. Hard to tell what's wrong with it w/o looking at it.

Ok, I fixed it, hope it helps!

Ok, I added more detail, hope it helps!

Unfortunately you left out the log file asked (i.e. /var/log/webcamd.log). And that's assuming you're using OctoPi, if not then you should know where that log file lives and how to retrieve it.

I don't have anything helpful to add, but as the creator of the OctoPrint Connection plugin it is nice to read that my plugin is doing something right that does not work in OctoPrint for a change :wink:

Im running octoprint on a old acer laptop, running linux, I have set up jpeg streamer properly, and when I go to MyIp:8080 I get the mjpeg streamer webpage, and it gives me a still image too, but when I click the "Stream" button, the page keeps loading forever

Sorry but I still have a bunch of questions to better understand the issue:

Which distribution? Ubuntu, Debian, Fedora, CentOS, ArchLinux, Alpine Linux, other? Which version? Is the laptop connected to WiFi, or through an ethernet cable?

Do you have HAProxy or another reverse proxy set up? Otherwise the streaming URL you've provided shouldn't work... If so can you also provide the configuration file you used, and the program version?

What are the streaming parameters you've provided to mjpg_streamer? And how do you start it? Systemd service, other? If so you should have a log of the output of mjpg_streamer that you could post here.

Ok got it fixed, it was a firewall on my computer, so it was my computer not octoprint. Once I removed the firewall, it worked perfectly!