Stream URL not working while snapshot does

Camera model

Arducam 5mp OV5647 camera

What is the problem?

I try to set the Pi up, but when I get to the camera setup, the stream URL doesn't work. The snapshot URL works fine, but the second I try to test the stream, nothing shows on the screen.

What did you already try to solve it?

I had a different problem before, but I troubleshooted using recommendations on this website to fix the original problem. I have ran in safe mode, typed in every command that Bing Ai would give me, and tried reflashing octoprint. The camera itself works, because the snapshot works. I tried typing in the stream url and opening it in a browser. “Http://myIP/ I also tried “sudo system to restart webcamd”.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (8.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I have the newest stable version of OctoPi on the flashing software, my pi is a 3B, I haven’t connected it to the printer. It is connected to an Ethernet cable, and I have high-speed Wi-Fi, so connectivity is not an issue. It is connected to an Arducam in a case, and I don't think the camera itself is the problem, because the snapshot URL works.

Did that work?

No, but for some reason when I connected to OctoPod on my phone yesterday, it suddenly showed the stream. It still won't show up on my computer, though. I have no idea why it worked on the app and not the site. Oh, well.