Stuck in Unknown File Print

I cannot print anything using OctoPrint as it seems to be stuck in endless print with an unknown file. Clicking Disconnect also will not work. Also when it cannot detect a printer it won't let me click Disconnect, although it shouldn't be an option.

I have re-installed OctoPrint entirely, not uploading any backups in the setup page.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Used Raspberry Pi Imager to install OctoPrint. It used to work just fine but one day just stopped working.

From your screen shot, it seems that the serial port on your printer is not being detected. The way this works is that there is a chip on the printers board that tells the Pi that its a serial port even though it is connected to a USB port. But this does not seem to be happening.

Few things I would check out of the gate...
Cable, Always try a new cable. Make sure its a data capable cable.
Next if a new cable does not help, you should suspect your printers main board or at least the chip I mentioned earlier. Maybe your printers Serial port is the issue.

You should check to see if it is even responding as a serial port by connecting the USB Cable to a laptop or other PC device that you can run a standard Serial terminal program like putty or even an arduino IDE instance can be used.

If you don't get anything from the printer.. (on windows, you should get a new serial port number to show up.. Most of the time it will even make a noise when you plug in the printer. Other OS types will be different but you should be able to use whatever standard terminal for your OS is to connect.

Getting the baud right will be key to read the data but really event if that is wrong, you should see something maybe garbage but you will at least know its trying.

Once you know your printer is ok. you can then bring the attention to your Pi. Maybe there is an issue with the USB ports there. Do you know if a keyboard works if you plug it into the same port? It's a simple test. If that does not work. Could be a hardware issue with your Pi.

Try some of the above and let us know the results.

It would also be good to try to provide the Systeminfo Bundle as well. (Hint: Click on that link to learn how to do that)

Thank you so much. I haven't tired your solution yet, but I left it alone and it somehow solved itself. Weird software issue I bet. Thank you for your time writing this. Have a good rest of your day!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.