Stuck on webcam

What is the problem?

I had to reinstall Octoprint to get from 16 to 18. I followed the instructions on the website and installed my backup.
Prior to doing this my webcam was working just fine. Now it is stuck on the "Webcam Stream Not Loaded" screen. I have tried to go to:
[local ip]:8080/?action=stream
[local ip]/?action=stream
[local ip]:8080/webcam/?action=stream
[local ip]/webcam/?action=stream

So far nothing.

To complicate matters I have a 2nd Pi3 with the newest Octoprint installed on it running. When I go into the settings I see it's webcam is /webcam/?action=stream. I can see it's webcam. When searching for the answer to this, I did find one address that showed me the 2nd webcam, but now can't find it.

To make matters more difficult, I can't seem to log in via SSH.

What did you already try to solve it?


Have you tried running in safe mode?


Did running in safe mode solve the problem?

Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/98.0.4758.102 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1400
env.hardware.ram: 915718144
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.7.3
systeminfo.generator: systemapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Newest install following directions found here:


I reflashed the OS and now I can see the webcam from the control and all the tests work EXCEPT for "Path to FFMPEG" It says: /usr/bin/avconv
But when I test I get: The path doesn't exist

From this thread it appears it may be related to backup/restore but I don't understand how to fix. I did SSH into the PI and tried WHICH FFMPG and it gave me the above path.

Not sure how to fix.

Here is the system Info (33.2 KB)

Here are the logs that have today's date
octoprint.log (249.5 KB)
plugin_octolapse.log (1.6 KB)
serial.log (444 Bytes)

I looked in config.yaml for the webcam info and this is what it has. Note the path is different. I did try the below but it too didn't work.
ffmpeg: /usr/bin/avconv
flipH: true
flipV: true
snapshot: http://[public ip]:8080/?action=snapshot
stream: http://{personal Ip}:8080/?action=stream
streamRatio: '4:3'
fps: 30
minDelay: 2.0
retractionZHop: 0.0
postRoll: 5
type: zchange
watermark: false

Damn it.

Rebooted and now it works.

Sometimes technology sucks.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.