Sudden problems connecting to RPi with CR10 attached


#1

What is the problem?
After months of problem-free activity, I'm suddenly having all kinds of problems connecting Octoprint, and when it does connect, then connecting to my CR10 Mini. When the printer is plugged in, I get extraordinarily long ping times to the Pi from my computer, consistently over 1000ms. When the printer is unplugged, the pings are typically <5ms. Sometimes, my browser (Chrome running under Linux Ubuntu 14.04) won't connect to octopi.local, nor to the explicit wired and wireless addresses (I use static IP addressing, so those don't change). Other times it will connect to the Pi and start the Octoprint interface, but Octoprint won't connect to the printer ("Failed to autodetect serial port, please set it manually"). And every once in while, it will all connect and work. I've not determined any repeatability.

I'm wondering if it's a hardware problem and I need a new Pi. But if the problem is the USB port on my printer....

What did you already try to solve it?
I've tried rebooting and power cycling the Pi, rebooting and power cycling my router, using both wired and wireless interfaces, changing USB cables, changing USB ports, even downloading a new OctoPi image on a different SD card.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

I'm running Octoprint 1.3.10 and OctoPi 0.15.1 and 0.16. My printer is a CR10-Mini. I connect via Chrome under Ubuntu 14.04.


#2

What happens when you start it in Safe Mode, is it any better?


#3

I didn't know there was a safe mode. How do I start it?


#4


#5

I'm kinda embarrassed I didn't know that! Guess that's a testament to how stable my system has been.

No joy, however. So I guess it's not an add-on. But I didn't think so, since I tried running with a brand-new install.


#6

So. It sounds like something happened on your network, possibly your wifi router or DHCP server. You indicate that it's better when you connect over Ethernet cable.

  • You didn't indicate whether or not your serial cable has internal metallic shielding or a ferrite core. It's possible that electronic noise from your printer's driver circuits is interfering with your wifi connectivity. Review the quality of your serial cable.
  • This could be power-related. Imagine if 5V power is being sinked from the Raspi over to your controller board, lowering the power available on the Raspi down to some point where it's just not working correctly at the proper 3.3V logic level. Review the quality of your 5V power adapter and anything that's plugged into the Raspi like camera, USB thumbdrive, Raspberry hat, TFT, mouse/keyboard, etc. Are you seeing any undervoltage indications in OctoPrint and is the Pi Support plugin installed and enabled?
  • I've personally had problems related to... my neighbors and THEIR wifi zones. I live in an apartment complex and I can routinely see about 30 wifi zones of different strengths. Up until just recently I saw my upstairs neighbors' wifi zone stronger than my own in my other room. But I bought Orbi room wifi routers and now I'm kicking some butt on that front. Note that there are many things that can affect wifi strength like old-school radiators, large aquariums, etc.

#7

As I stated, I have the same problems over WiFi and ethernet. I'll look into the power issues as you suggested and respond. Thanks.


#8

I've never seen an undervoltage indication in Octoprint. Yes, Pi Support is enabled. I'm using the Canakit power supply that came with it, connected to a UPS. I tried connecting directly to the wall outlet, too.

I've confirmed (I think) that it's not a networking issue. I can connect to the Pi instantly via the browser interface, if the Pi is not plugged in to the printer. As soon as I plug it in, I start having connection issues to Octoprint and to the printer.

I've changed USB ports on the Pi and changed USB cables: no joy. Are there any diagnostics I can look at to see if the Pi is having problems recognizing the printer? Is it likely a Pi hardware problem, a printer hardware problem, or something else?

Thanks.


#9

What I'm hearing is...

  • things are fine with respect to connecting either via Ethernet cable or wifi... until I add the serial cable (or was that "until I press the Connect option"?)
  • after I connect, I get "connection issues"... by which you must mean that—I'm guessing—the Pi is slow to respond or it takes three minutes to reload the page or sometimes it doesn't even respond

I think I'd add a keyboard/mouse/monitor on the Pi and run htop there, watching what's going on. I would look at the amount of available RAM. Okay, so we don't know if you're using a four-core Raspi with a full 1GB of RAM or something less than this. If you are using a Pi Zero or something older than a 3B (or even a 3A+) then an upgrade may be in order.

Let's see... we didn't talk about peripherals. We assume that you're using a USB-based serial cable and not using GPIO pins to talk to your printer so a battle over the good UART isn't happening.

You would think that this isn't related to any sort of power-saving feature that's trying to go into sleep mode on either of your network devices. We have to assume that you're not using something like uhubctl to toggle ON/OFF power to things (possibly accidentally turning off power to networking). We have to assume that you didn't load the PIXEL/Desktop interface. We have to assume that you are running this headless (no TFT/monitor) and that you haven't adjusted the gpu_mem setting in your config.txt. We have to assume that you haven't changed your swapfile settings. In theory, any of those could negatively affect you.

If it were me, I'd drop in a Raspi 3B or 3B+ and see if the problem goes away (binary search sort of troubleshooting).


#10

Yes, all of your assumptions are accurate, although it doesn't connect to the printer. Pressing the Connect button just gives me the "Failed to connect to serial port" error.

No peripherals, no GPIO. It's the CanaKit Raspberry Pi 3 from Amazon, purchased last May. I don't mind (too much) getting a new Pi if that will fix it, but if it's something on the CR10 side...

I'll hook up a monitor/mouse/keyboard and poke around. What does htop do?


#11

htop will show you a running report of statistics about what's running.


#12

Ran htop. I'm using about 20% of the memory. Nothing else jumped out at me.


#13

If this were me, I'd swap out the Raspberry to see if this is the cause.


#14

I replaced my Pi 3B with a new 3B+ and everything's working now. I guess it was a Pi hardware problem.

Thanks for all the advice!


#15

If this were me, I think I would take the old Pi to the bench and re-solder the connections and chips in the section near the RJ-45 connector and re-test. Likewise for the connections on/near that micro-USB connector.

I would also compare/contrast how well the USB Type-A serial cable connection fits into both as well as the micro-USB power plug.