Suddenly having issues after uploading files to OctoPrint

What is the problem?

As of yesterday after not changing any plugins or anything, I slice and upload a file from Cura and it uploads fine. After pressing "Load and Print" the print "starts" and then immediately goes to 100% without heating up or printing anything. Then I get an octoeverywhere email saying that the print finished in .257 ish seconds...

What did you already try to solve it?

I tried re-establishing the cura connection by deleting the cura plugin and connecting my printer again, I've tried running in safe mode to rule out any faulty plugins, and saving the print to my computer and then manually uploading to octoprint. I have tried disabling and uninstalling the Print Time Genius plugin multiple times and I get the same issue.

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No, problem persists even in safe mode.

Systeminfo Bundle

octoprint-systeminfo-20240310002752.zip (109.9 KB)

Included systeminfo zip

Additional information about your setup

Neptune 3 Plus, Octoprint running on Rasp pi 3, Using Cura 5.5.0 and Octoprint version 1.93. I've been printing for a few years but still know almost nothing about Octoprint and how it functions. I just click the Print with Octoprint button and it does all the work for me...

Hello @BusterCulver !

Is this just with a certain gcode file or all?
As for the log, you always tried the same file.

Can you share a small gcode file that issues this problem?

I realize now that it may have been a cura plugin causing the problem. The issue only seems to happen when trying to print using the Auto Towers models that are baked into the Auto Tower plugin. I'll test again when my print finishes.

Never mind. That theory was wrong. I tried printing something other than an "Auto Towers" model with Print Time Genius and it says "Waiting for OctoPrint to complete G-code Analysis" forever. When I press "print now" it does the same thing where it uploads to Octoprint but then finishes immediately without even heating up. I tried uninstalling Print Time Genius again and it still gives me the Waiting for G-code analysis dialog forever. So I'm at a loss. Not even slicing it and saving it to my pc and then manually uploading to OctoPrint works anymore. Somehow I was able to print something overnight using the regular method with slicing and sending it straight to Octoprint, but I don't remember doing anything differently other than not having print time genius installed. I'll attach the most recent systeminfo below.

octoprint-systeminfo-20240310152416.zip (298.7 KB)

Could you share the gcode file that you're trying to print as well?

From the logs, OctoPrint thinks that the file has no extrusions in it.

1 Like